Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 254561 - rpm spec mode can't output to buffer when rpm-build-all
Summary: rpm spec mode can't output to buffer when rpm-build-all
Keywords:
Status: CLOSED DUPLICATE of bug 227418
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs
Version: 7
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Chip Coldwell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-25 23:40 UTC by J. Randall Owens
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-26 06:14:53 UTC


Attachments (Terms of Use)

Description J. Randall Owens 2007-08-25 23:40:03 UTC
Description of problem:
In rpm-spec-mode, when building a package from the spec file in your buffer, it
usually (always?) complains that the buffer is read-only, and does not display
the rpmbuild output as I had come to expect in earlier versions.

Version-Release number of selected component (if applicable):
emacs-22.1-1.fc7
emacs-common-22.1-1.fc7

How reproducible:
Attempt to build an (S)RPM from a specfile (seems to also happen with prep,
build, install) within an emacs buffer.

Steps to Reproduce:
1. open foo.spec in emacs
2. C-c C-b a (rpm-build-all)
  
Actual results:
In the minibuffer:
error in process filter: Buffer is read-only: #<buffer *rpmbuild -ba foo.spec*>
In the output buffer:
error in process filter: Buffer is read-only: #<buffer *rpmbuild -ba foo.spec*>
error in process filter: rpm-command-filter: Buffer is read-only: #<buffer
*rpmbuild -ba foo.spec*>
(repeated many times, but probably not as many as once for each line of output)

Expected results:
The usual rpmbuild output

Additional info:
I'm not sure just where /usr/share/emacs/site-lisp/rpm-spec-mode.el comes from;
I grabbed the SRPM to see, and all I know now is that it's not part of the
standard emacs tarball.
I don't know much about Lisp or emacs internals, but I'd guess the problem lies
between line 957 and 1010, where function rpm-build is defined. Perhaps you need
to setq a read-only variable for the buffer?

I don't think anything in my .emacs would do it, but here it is just in case
(some minor and obvious obfuscation):
(custom-set-variables
  ;; custom-set-variables was added by Custom.
  ;; If you edit it by hand, you could mess it up, so be careful.
  ;; Your init file should contain only one such instance.
  ;; If there is more than one, they won't work right.
 '(backup-by-copying-when-linked t)
 '(case-fold-search t)
 '(column-number-mode t)
 '(current-language-environment "Latin-1")
 '(default-input-method "latin-1-prefix")
 '(fringe-mode 0 nil (fringe))
 '(global-font-lock-mode t nil (font-lock))
 '(inhibit-splash-screen t)
 '(inhibit-startup-echo-area-message "foobar")
 '(mail-self-blind t)
 '(show-paren-mode t nil (paren))
 '(transient-mark-mode t)
 '(user-mail-address "foo+bar@example.net"))
(custom-set-faces
  ;; custom-set-faces was added by Custom.
  ;; If you edit it by hand, you could mess it up, so be careful.
  ;; Your init file should contain only one such instance.
  ;; If there is more than one, they won't work right.
 )

Comment 1 J. Randall Owens 2007-08-26 06:14:53 UTC

*** This bug has been marked as a duplicate of 227418 ***


Note You need to log in before you can comment on or make changes to this bug.