Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2531 - rpm doesn't check if partitions are mounted read/write
Summary: rpm doesn't check if partitions are mounted read/write
Keywords:
Status: CLOSED DUPLICATE of bug 4098
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-04 05:08 UTC by Marc MERLIN
Modified: 2015-01-07 23:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-09-14 18:09:59 UTC


Attachments (Terms of Use)

Description Marc MERLIN 1999-05-04 05:08:48 UTC
On my systems /usr and /usr/local are always mounted
read/only, like they were meant to be.
The problem is that when I try to install an rpm, it may
do an incomplete install, but especially if I remove an
existing rpm, it will be removed from the database without
its files being removed from /usr.

So far, I've worked around this problem by moving
/var/lib/rpm to /usr/lib/rhs/rpm, which prevents rpm from
getting a lock on the dabase if /usr is mounted read only,
but it'd be much better if RPM checked if it has write
permissions before doing anything, and abort right away,
instead of doing half the job and bailing out later

Comment 1 Jeff Johnson 1999-05-04 17:32:59 UTC
Rpm was not designed to manage packages on file systems, some
of which are mounted read-only. Maybe some day ...

Comment 2 Jeff Johnson 1999-08-19 15:17:59 UTC
*** Bug 4098 has been marked as a duplicate of this bug. ***

rpm fails to realize it cannot write  when /usr is mounted
RO and an rpm -e or rpm -U
is done.

Result: partly updated  /deleted rpms that are marked as
updated/deleted in the rpm database.

rpm needs to check if it can write on a filesystem

------- Additional Comments From jturner@redhat.com  07/19/99 09:42 -------
This issue has been assigned to a developer for further action.

Comment 3 Jeff Johnson 2001-01-08 16:17:42 UTC

*** This bug has been marked as a duplicate of 4098 ***


Note You need to log in before you can comment on or make changes to this bug.