Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2509 - RFE: persistent per-package notification field
Summary: RFE: persistent per-package notification field
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Bugzilla
Classification: Community
Component: Bugzilla General
Version: 2.18
Hardware: All
OS: Linux
medium
medium vote
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL: http://bugzilla.mozilla.org/show_bug....
Whiteboard:
: 6693 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-03 17:54 UTC by Jeff Johnson
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-23 19:28:43 UTC


Attachments (Terms of Use)

Description Jeff Johnson 1999-05-03 17:54:46 UTC
I'd like to see a way for someone to register for
notification of any activity for a package. This field
would be useful for auto-notifying interested parties
(e.g. package maintainers) of creation/fixing of a newly
found bug.

Comment 1 Anonymous 1999-05-04 02:32:59 UTC
Yes, I'm working on this too.  The idea is to be able to modify who
gets emailed updates.  That can be any bugzilla member or a certain
number of pre-declared people.  You'd be able to turn yourself off.

The format of the updates is a bit awkward, too.  We might be
expecting a bit much to assume that everyone can can read diff files.

We could optionally take QA and devel owner lists out of the depends
database and have those as defaults.

- Alex

Comment 2 David Lawrence 1999-11-19 23:18:59 UTC
*** Bug 6693 has been marked as a duplicate of this bug. ***

Comment 3 Pekka Savola 2000-11-21 17:17:10 UTC
Reminder. 

These features discussed earlier, in 1999, are more sorely needed than ever.  

One use would be to keep original package maintainers up-to-date, but there are
also a lot of people in the community who would be willing to help with packages.

Also, along the same lines: You should be able to turn off notifications if more people 
are added in Cc: line.  Not really exciting information, in itself...


Comment 5 David Lawrence 2003-01-14 23:19:57 UTC
We have ability now to have the default cclist for a component, it is currently
only accessible by those who have edit componentes privs. I supposed what you
are asking for is the the ability for individuals to list components that they
want to be automatically added to the cclist when new bugs are created. This
would have to be strictly checked to make sure they have prior permission to see
the new bug in the first place since by default people on cc lists can see
private bugs.

Comment 6 Jeff Johnson 2003-01-15 14:43:08 UTC
THe original RFE was for some way to notify upstream
maintainers. I'm not sure that automagic (i.e. bugzilla
not user, enters CC: field) makes as much sense now
as it did then.

Comment 7 David Lawrence 2005-08-23 19:28:43 UTC
No longer relevant due to new release of Bugzilla. Please reopen as new bug if
these requests are still needed.


Note You need to log in before you can comment on or make changes to this bug.