Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2497 - When 8859-2 package is installed path is not added to xfs configuration!
Summary: When 8859-2 package is installed path is not added to xfs configuration!
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86-ISO8859-2
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-03 08:09 UTC by alien
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-11 18:17:01 UTC


Attachments (Terms of Use)

Description alien 1999-05-03 08:09:11 UTC
Installing 8859-2 package won't automatically add path to
new fonts in xfs configuration! (/etc/X11/xfs/), so fonts
are unavailable f not added by hand!

Comment 1 Milan Kerslager 1999-06-07 22:01:59 UTC
This is caused by installation proces. When fonts are installed no
xfs server is in system yet. The solution is use triggered
postinstall scripts. Triggerred version you can found there:
ftp://ftp.spsselib.hiedu.cz/pub/users/Kerslager/RedHat-6.0/XFree86-IS
O8859-2*
I tryed to use Prereq: in spec file but this didn't work. Triggers
are the best way to solve this problem.

------- Email Received From  Milan Kerslager <milan.kerslager@spsselib.hiedu.cz> 06/07/99 18:37 -------

Comment 2 Preston Brown 1999-06-11 18:17:59 UTC
The ISO 8859-2 fonts we ship prerequire chkfontpath, and chkfontpath
requires xfs, so if you have both of these packages on the system,
everything should happen automatically.

If you are experiencing problems with the path not being added at
_initial installation time_, this is a known bug in RPM (it doesn't
reorder the dependency list 100% correctly).  There is a fix on the
errata page for Red Hat 6.0 (i.e. manually run chkfontpath to add the
paths).

After this, installing packages that use chkfontpath to modify the
font path should work smoothly.


Note You need to log in before you can comment on or make changes to this bug.