Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 249532 - rpm-spec-mode.el not working?
Summary: rpm-spec-mode.el not working?
Keywords:
Status: CLOSED DUPLICATE of bug 227418
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Chip Coldwell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 227418
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-25 13:32 UTC by Neal Becker
Modified: 2007-11-30 22:12 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-28 13:49:23 UTC


Attachments (Terms of Use)
rpm-spec-mode as a real compilation mode (deleted)
2007-09-10 13:33 UTC, Chip Coldwell
no flags Details
rpm-spec-mode using a real compilation mode (deleted)
2007-11-28 15:23 UTC, Chip Coldwell
no flags Details

Description Neal Becker 2007-07-25 13:32:53 UTC
Description of problem:

Does rpm-spec-mode work for you?  I'm using current emacs devel spec file, but 
with emacs cvs source.  Using \c-c \c-b a (build all) gives nasty error.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Yoshinori KUNIGA 2007-08-02 07:43:29 UTC
Some commands including 'C-c C-b i' and 'C-c C-b p' works fine by
applying patch of bugzilla #227418.

But 'C-e C-e' does not work with following message.

  Invalid function: ignore-errors

Comment 2 Tom Tromey 2007-09-09 05:51:33 UTC
That is odd since, AFAICT, ignore-errors is autoloaded from cl-macs.
(And, if not, there's a compatibility defmacro in rpm-spec-mode.el.)
Maybe try (require 'cl-macs).


Comment 3 Chip Coldwell 2007-09-10 13:33:58 UTC
Created attachment 191641 [details]
rpm-spec-mode as a real compilation mode

I've been working on changing rpm-spec-mode to use a real compilation mode.  I
think this is a better way to fix the problem than to patch up the existing,
rather kludgey version.  Compare, for example, grep.el.

Chip

Comment 4 Jens Petersen 2007-10-15 05:37:34 UTC
I just noticed this too after upgrading the latest emacs package for F7. :-(

Comment 5 Jens Petersen 2007-10-15 05:51:49 UTC
Re-bytecompiling rpm-spec-mode.el by hand seems to fix the problem.
Not sure why it is broken or if rpm-spec-mode.el should require cl-macs at
compile time.

Comment 6 Jens Petersen 2007-10-15 05:56:15 UTC
Ah I see there is bug 306841 for ignore-errors.

Comment 7 Laurent Rineau 2007-11-14 18:32:44 UTC
(In reply to comment #3)
> Created an attachment (id=191641) [edit]
> rpm-spec-mode as a real compilation mode

Great!

Note: I had to add "(require 'compile)" at the beginning of the file. Without 
it, `define-compilation-mode was not known by Emacs.

I am look forward to see that file in Fedora...


Comment 8 Chip Coldwell 2007-11-28 13:49:23 UTC

*** This bug has been marked as a duplicate of 227418 ***

Comment 9 Chip Coldwell 2007-11-28 15:23:54 UTC
Created attachment 271411 [details]
rpm-spec-mode using a real compilation mode

Here's a first cut at an rpm-spec-mode that uses a real compilation mode.  Give
it a try and report any bugs.

One thing that I know work is signing rpms automagically after build.

Chip

Comment 10 Laurent Rineau 2007-11-28 15:47:35 UTC
Tested once.(In reply to comment #9)
> Created an attachment (id=271411) [edit]
> rpm-spec-mode using a real compilation mode
> 
> Here's a first cut at an rpm-spec-mode that uses a real compilation mode.  
Give
> it a try and report any bugs.

Tested once. Works fine. I have added it to my load path, and will test 
regularly.

RPM signing does *not* work.


Comment 11 Chip Coldwell 2007-11-28 16:05:47 UTC
(In reply to comment #10)
> 
> RPM signing does *not* work.

Yes, that was what I meant to say in my previous, mangled comment.

Once we've worked out all the bugs and have all the functionality back, I want
to push this change upstream.  It seems logical to me that rpm building should
be done in a compilation buffer.

Chip





Note You need to log in before you can comment on or make changes to this bug.