Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2484 - /etc/X11/xdm/Xsession - quotes needed
Summary: /etc/X11/xdm/Xsession - quotes needed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
: 2392 2894 3000 3432 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-02 21:36 UTC by tudor
Modified: 2008-05-01 15:37 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-17 14:54:46 UTC


Attachments (Terms of Use)

Description tudor 1999-05-02 21:36:22 UTC
Hi,

I'm not sure how /etc/X11/xdm/Xsession is generated, but
the color in the call to xsetroot should be quoted, i.e.

xsetroot -solid #356390

should be replaced with

xsetroot -solid "#356390"

Regards,
Tudor

Comment 1 Jeff Johnson 1999-06-03 15:15:59 UTC
*** Bug 3000 has been marked as a duplicate of this bug. ***

in /etc/X11/xdm/Xsession 4th line is :
xsetroot -solid #356390
I do not know what does this mean but it always gives a
syntax error , every time I try to log in , with the
following message:

usage: xsetroot [options]
  where options are:
  -display <display>   or   -d <display>
  -fg <color>   or   -foreground <color>
  -bg <color>   or   -background <color>
  -rv   or   -reverse
  -help
  -def   or   -default
  -name <string>
  -cursor <cursor file> <mask file>
  -cursor_name <cursor-font name>
  -solid <color>
  -gray   or   -grey
  -bitmap <filename>
  -mod <x> <y>
What is the problem ?


------- Additional Comments From notting@redhat.com  05/24/99 09:58 -------
it's a bug in the Xsession file. Put quotes around the
color spec.

Comment 2 Jeff Johnson 1999-06-03 15:19:59 UTC
*** Bug 2392 has been marked as a duplicate of this bug. ***

In /etc/X11/xdm/Xsession you can find this:

xsetroot -solid #356390

and because it's a shell script, hash mark starts a comment.
I am sure we don't want this. To correct it:

xsetroot -solid \#356390

Comment 3 Jeff Johnson 1999-06-03 18:47:59 UTC
*** Bug 2894 has been marked as a duplicate of this bug. ***

In /var/log/xdm-error.log, the following error messages
appear.

stdin: is not a ttyusage: xsetroot [options]
  where options are:
  -display <display>   or   -d <display>
  -fg <color>   or   -foreground <color>
  -bg <color>   or   -background <color>
  -rv   or   -reverse
  -help
[...] etc.

xsetroot is obviously being called in a broken way by
something

------- Additional Comments From dlt@redhat.com  05/18/99 15:25 -------
This appears to be due to a problem in the X startup scripts.  It will
be fixed sometime later.  It does not appear to have any functional
implication.

Comment 4 Jeff Johnson 1999-06-13 18:44:59 UTC
*** Bug 3432 has been marked as a duplicate of this bug. ***

The scripts

/etc/X11/xdm/{Xsession,Xsetup_0}

both contain the line

xsetroot -solid #356390

which are incorrect and should be replaced by

xsetroot -solid rgb:35/63/90

Comment 5 Bill Nottingham 1999-06-17 14:54:59 UTC
Fixed in errata XFree86-*-52 release.


Note You need to log in before you can comment on or make changes to this bug.