Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 248273 - yum segfaults during installation of glibc
Summary: yum segfaults during installation of glibc
Keywords:
Status: CLOSED DUPLICATE of bug 213963
Alias: None
Product: Fedora
Classification: Fedora
Component: 4Suite
Version: 6
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-14 21:56 UTC by Marek Mahut
Modified: 2014-01-21 22:58 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-07-17 19:10:43 UTC


Attachments (Terms of Use)

Description Marek Mahut 2007-07-14 21:56:47 UTC
Description of problem:

Yum segfaults during update of system installed from CD. It crashes when
upgrading glibc.

Version-Release number of selected component (if applicable):

yum 3.0

How reproducible:

always

Steps to Reproduce:
1. install system
2. upgrade by 'yum update'
  
Actual results:

yum segfaults on glibc

Expected results:

yum should upgrade glibc without problem 

Additional info:

n/a

Comment 1 Marek Mahut 2007-07-14 22:32:10 UTC
Versions:

yum-3.0-6
yum-metadata-parser-1.0-8.fc6
glibc-2.5-3
glibc-2.5-18.fc6


Comment 2 Seth Vidal 2007-07-15 00:11:19 UTC
Is glibc the only thing in the update transaction when the segfault occurs?

Can you recreate the segfault consistently?

If you can do the above does it happen when you run rpm -Uvh on the same set of
packages?


Comment 3 Panu Matilainen 2007-07-17 18:59:12 UTC
I'd say this is yet another dupe of #213963, FC6 freshly installed from CD has a
kernel with the mmap-bug-of-death that causes segfaults with rpm all over the
place. 

Comment 4 Marek Mahut 2007-07-17 19:09:45 UTC
I didn't have change to access that machine yet, I will over the weekend.
Regarding the bug #213963 from Panu, I can agree that it's the same problem. 

I mark this bug as a duplicate of #213963 and will continue the troubleshooting
there if needed.

Thank you Seth and Panu.

Comment 5 Marek Mahut 2007-07-17 19:10:43 UTC

*** This bug has been marked as a duplicate of 213963 ***


Note You need to log in before you can comment on or make changes to this bug.