Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2476 - problem doing noarch -ba
Summary: problem doing noarch -ba
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 6.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-01 21:45 UTC by genec
Modified: 2015-01-07 23:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-11 15:30:28 UTC


Attachments (Terms of Use)

Description genec 1999-05-01 21:45:55 UTC
rpm gets a segmentation fault doing a "-ba" for a noarch
rpm.  This occurs with rpm 3.0-6.0 on rhl 6.0.  This seems
fairly repeatable but additional info available if needed.

This was run on a PII.  Removing the BuildArchitectures:
noarch so that it build an "i386" version worked.

Gene

Comment 1 Bill Nottingham 1999-05-03 03:51:59 UTC
fixed in rpm-3.0.1-1, available in latest rawhide

Comment 2 genec 1999-05-08 14:27:59 UTC
fix in rawhide (1.3.5) works.  However, why isn't this an update to
rhl 6.0.  It seems to me that this is a SIGNIFICANT bug in rpm.

Gene

Comment 3 Jeff Johnson 1999-05-11 15:30:59 UTC
This will be an update to Red Hat 6.0.


Note You need to log in before you can comment on or make changes to this bug.