Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 246815 - libYap.so is missing from the %files section
Summary: libYap.so is missing from the %files section
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yap
Version: 7
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Gérard Milmeister
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-05 06:55 UTC by Roberto Bagnara
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-07-06 14:36:36 UTC


Attachments (Terms of Use)

Description Roberto Bagnara 2007-07-05 06:55:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

Description of problem:
Here is the %files section of the SPEC file:

%files devel
%defattr(-,root,root,-)
%{_prefix}/lib/libYap.a
%{_includedir}/Yap

As you can see, there is no mention of libYap.so.  This makes it impossible to use YAP's foreign language interface using dynamic linking.


Version-Release number of selected component (if applicable):
yap-5.1.1-3

How reproducible:
Always


Steps to Reproduce:
Try, e.g., to use the foreign language interface on an x86_64 machine with dynamic linking.  Since libYap.so cannot be found, libYap.sa will be used with the following result:

/usr/bin/ld: /usr/lib/libYap.a(c_interface.o): relocation R_X86_64_32S against `Yap_REGS' can not be used when making a shared object; recompile with -fPIC
/usr/lib/libYap.a: could not read symbols: Bad value


Actual Results:


Expected Results:


Additional info:

Comment 1 Gérard Milmeister 2007-07-05 08:52:43 UTC
Please build this:
http://math.ifi.unizh.ch/fedora/tmp/yap-5.1.1-4.fc7.src.rpm
on a x86_64 (I don't have a x86_64 to try on) and report
back.

Comment 2 Roberto Bagnara 2007-07-05 10:28:09 UTC
It works!



Note You need to log in before you can comment on or make changes to this bug.