Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 246722 - backport receive window mgmt code to for SCTP to RHEL5
Summary: backport receive window mgmt code to for SCTP to RHEL5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Neil Horman
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks: 249316 420521 422431 422441
TreeView+ depends on / blocked
 
Reported: 2007-07-04 13:30 UTC by Neil Horman
Modified: 2018-10-19 20:24 UTC (History)
2 users (show)

Fixed In Version: RHBA-2008-0314
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-05-21 14:45:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0314 normal SHIPPED_LIVE Updated kernel packages for Red Hat Enterprise Linux 5.2 2008-05-20 18:43:34 UTC

Description Neil Horman 2007-07-04 13:30:13 UTC
Description of problem:
The current RHEL5 sctp implementation has a problem in which an associations
receive memory can be exhausted prior to its rwnd closing.  I've fixed it
upstream and it needs to be backported

Comment 1 RHEL Product and Program Management 2007-07-04 13:35:51 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 2 Neil Horman 2007-08-29 14:43:08 UTC
*** Bug 210208 has been marked as a duplicate of this bug. ***

Comment 3 Russell Doty 2007-08-31 17:17:45 UTC
Since Bug 210208 was closed as a duplicate, I am moving all of the RHEL 5.2
request settings to this BZ.

Comment 5 Don Zickus 2007-11-29 17:06:19 UTC
in 2.6.18-58.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5

Comment 6 Issue Tracker 2007-12-04 20:08:26 UTC
Ran a quick iperftp test on CPI1 installed by Patrick.

Linux stitch-1-2.testing.local 2.6.18-58.el5PAE #1 SMP Tue Nov 27 17:15:24
EST 2007 i686 i686 i386 GNU/Linux
1 bytes : [  3]  3.0- 6.0 sec  0.09 MBytes  0.25 Mbits/sec
2 bytes : [  3]  3.0- 6.0 sec  0.18 MBytes  0.51 Mbits/sec
4 bytes : [  3]  3.0- 6.0 sec  0.32 MBytes  0.89 Mbits/sec
8 bytes : [  3]  3.0- 6.0 sec  0.74 MBytes  2.07 Mbits/sec
16 bytes : [  3]  3.0- 6.0 sec  1.47 MBytes  4.10 Mbits/sec
32 bytes : [  3]  3.0- 6.0 sec  2.44 MBytes  6.82 Mbits/sec
64 bytes : [  3]  3.0- 6.0 sec  5.01 MBytes  14.0 Mbits/sec
128 bytes : [  3]  3.0- 6.0 sec  11.7 MBytes  32.6 Mbits/sec
256 bytes : [  3]  3.0- 6.0 sec  23.0 MBytes  64.3 Mbits/sec
512 bytes : [  3]  3.0- 6.0 sec  44.7 MBytes    125 Mbits/sec
1024 bytes : [  3]  3.0- 6.0 sec  89.9 MBytes    251 Mbits/sec
2048 bytes : [  3]  3.0- 6.0 sec    172 MBytes    480 Mbits/sec
4096 bytes : [  3]  3.0- 6.0 sec    316 MBytes    883 Mbits/sec
8192 bytes : [  3]  3.0- 6.0 sec    529 MBytes  1480 Mbits/sec
16384 bytes : [  3]  3.0- 6.0 sec    802 MBytes  2242 Mbits/sec
32768 bytes : [  3]  3.0- 6.0 sec  2.22 MBytes  6.20 Mbits/sec
65536 bytes : [  3]  3.0- 6.0 sec  0.50 MBytes  1.40 Mbits/sec

This time I'm getting some problems with 32K messages also, which makes
no sense to me as the default receive buffer seems to be bigger (in
/proc/sys/net/sctp/sctp_rmem) than it used to be.

Internal Status set to 'Waiting on Support'
Status set to: Waiting on Tech

This event sent from IssueTracker by streeter 
 issue 103872

Comment 11 errata-xmlrpc 2008-05-21 14:45:24 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html



Note You need to log in before you can comment on or make changes to this bug.