Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 246292 - createrepo no longer follows symbolic links
Summary: createrepo no longer follows symbolic links
Keywords:
Status: CLOSED DUPLICATE of bug 228827
Alias: None
Product: Fedora
Classification: Fedora
Component: createrepo
Version: 6
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-29 20:31 UTC by Marc Desrochers
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-07-29 13:21:14 UTC


Attachments (Terms of Use)

Description Marc Desrochers 2007-06-29 20:31:29 UTC
Description of problem:

    Version 0.4.10-1.fc6 does not follow symbolic links pointing to
    directories which contain RPM packages.  We use such links to
    simplify managing our local repositories when, e.g., we have
    i386-specific RPM packages but no x86_64-specific ones, pointing
    the x86_64 repository to the i386 one, e.g. :

        Browser_plugins -> ../i386/Browser_plugins

    According to the man page and "createrepo -h", there appears to
    be no flag to force it to follow symbolic links.

    Version 0.4.4-2.fc6 did follow symbolic links.

Version-Release number of selected component (if applicable):

    0.4.10-1.fc6

How reproducible:


Steps to Reproduce:
1. point symbolic link to a valid repository containing RPM packages
2. createrepo -v
3.
  
Actual results:
    Repository contains no RPM package information.

Expected results:
    Repository containing information on RPM packages in the
    hierarchy pointed to by the symbolic link.
    Or documentation on a flag to achieve following symbolic
    links, if such a flag now exists.

Additional info:

Comment 1 Seth Vidal 2007-07-29 13:21:14 UTC

*** This bug has been marked as a duplicate of 228827 ***


Note You need to log in before you can comment on or make changes to this bug.