Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2460 - Kickstart encrypts an iscrypted password
Summary: Kickstart encrypts an iscrypted password
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-01 05:20 UTC by gordon.m.tetlow
Modified: 2016-09-19 19:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-28 23:51:32 UTC


Attachments (Terms of Use)

Description gordon.m.tetlow 1999-05-01 05:20:33 UTC
When using kickstart to install a machine, I used an already
encrypted password. When it rebooted I couldn't log in as
root. After some investigating, I found out if I presented
the password hash I had specified in the kickstart file, it
would then let me log in.

In other words, during the install, the encrypted password
was encrypted again.

Comment 1 gordon.m.tetlow 1999-05-01 06:29:59 UTC
I checked the value of skipCrypt and found it to be 0 after the call
to poptGetContext inside of setRootPassword inside install2.c

This seems to be the problem, although why the poptGetContext is
returning skipCrypt as 0 is beyond me.

Gordon

Comment 2 David Lawrence 1999-05-10 19:52:59 UTC
I have verified this on a test lab machine.

Comment 3 David Lawrence 1999-05-10 19:54:59 UTC
*** Bug 2627 has been marked as a duplicate of this bug. ***


When doing a kickstart installation with RedHat 6.0
(kickstart is great!) and writing something like

rootpw --iscrypted 8d78LWoez74ef

in the kickstart file sets the root password to "8d78LWoe".
--iscrypted still worked in 5.2.  I quickly looked through
the code in install2, but there were little changes in
the password code, so I could not figure the problem out.
I have --useshadow in auth config.

Comment 4 Matt Wilson 1999-05-28 23:51:59 UTC
*** This bug has been marked as a duplicate of 2880 ***

Comment 5 Mike Smith 1999-06-16 23:51:59 UTC
This issue is not resolved....I have downloaded the updated
bootnet.img and it is still doing the same thing. It is crypting
the iscrypted text

Comment 6 osi 1999-06-17 08:13:59 UTC
Yep, I can confirm this as well.  The bootnet image dated
May 28th did not fix the problem.

Comment 7 openshift-github-bot 2016-09-19 19:10:04 UTC
Commit pushed to master at https://github.com/openshift/openshift-ansible

https://github.com/openshift/openshift-ansible/commit/47a2e769d1cd462d213f1367122e6af8c862650e
Merge pull request #2470 from abutcher/issue2460

[uninstall] Stop services on all hosts prior to removing files.


Note You need to log in before you can comment on or make changes to this bug.