Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2459 - gnorpm has trouble with firewall and proxy server
Summary: gnorpm has trouble with firewall and proxy server
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnorpm
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-01 05:15 UTC by George Karabin
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-31 19:46:47 UTC


Attachments (Terms of Use)

Description George Karabin 1999-05-01 05:15:08 UTC
I am running gnorpm-0.8-5 on a new Redhat 6.0 installation
(upgrade), though I've have this problem with gnorpm on
older distributions for some time.

My machine sits behind a firewall that requires the use of a
proxy server. If I set the proxy-server name to some
non-null value, like "proxy" or "proxy:portnum", gnorpm
always crashes.

If I run gnorpm from the command line, it always starts up
with some warnings, like so:

------------------------------------
LibFind-Message: downloading
http://www.redhat.com/RDF/resources/distribs/metadata.rdf

LibFind-WARNING **: processing request failed

LibFind-WARNING **: Couldn't get data at
http://www.redhat.com/RDF/resources/distribs/metadata.rdf

LibFind-WARNING **: couldn't grab metadata server list

Gtk-CRITICAL **: file gtkcombo.c: line 817
(gtk_combo_set_popdown_strings): assertion `strings != NULL'
failed.
LibFind-Message: downloading
http://www.redhat.com/RDF/resources/distribs/list.rdf

LibFind-WARNING **: processing request failed

LibFind-WARNING **: Couldn't get data at
?J@?J@ww.redhat.com/RDF/resources/distribs/list.rdf
LibFind-Message: downloading
http://www.redhat.com/RDF/resources/distribs/metadata.rdf

---------------------------------------------
Whenever I try to open the preferences window, after having
set the proxy fields in an earlier invovcation, I get this
segfault message:
---------------------------------------------
LibFind-WARNING **: setting of proxy failed
zsh: 903 segmentation fault  gnorpm

Comment 1 James Henstridge 1999-05-03 10:53:59 UTC
This problem is caused by one of the patches against the
gnorpm-0.8.tar.gz tarball I released included in the RPM.  The patch
changes the default metadata server from http://rufus.w3.org/linux/RDF
to http://www.redhat.com/RDF

Unfortunately http://www.redhat.com/RDF is a broken link, which means
that the web find capability in gnorpm does not work at all.

There are two fixes for this:
1) Redhat mirrors the rpmfind metadata server (were you planning on
doing this?)
2) Edit your gnorpm preferences.  Go to the rpmfind tab, and change
the metadata server to http://rufus.w3.org/linux/RDF then restart
gnorpm.

If you still have proxy problems after this, make sure that the proxy
names are entered in http://server:port/ syntax.

James Henstridge.
(the gnorpm author)

Comment 2 George Karabin 1999-05-03 16:50:59 UTC
That made the difference for me. Everything seems to be working now -
thanks!

Comment 3 Matthew Galgoci 1999-05-13 21:57:59 UTC
GnoRPM does give a batch listing of packages that
are not installed  from a mixed group of installed/not installed
packages.

Comment 4 Jeff Johnson 1999-05-31 19:46:59 UTC
This problem appears to have been resolved. Please reopen if I'm
wrong.


Note You need to log in before you can comment on or make changes to this bug.