Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 245 - Install fails with a message..
Summary: Install fails with a message..
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-12-01 06:38 UTC by vladimip
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-01-12 03:41:25 UTC


Attachments (Terms of Use)

Description vladimip 1998-12-01 06:38:36 UTC
I submitted it ro 90-days RH techsupport but since they
haven't replied after almost two weeks I assume it can't
be easily solved and may be a bug. If you need more details
about the system please let me know. Some of (hopefully
relevant) info is attached at the end of this message.

I have a problem upgrading a system from 5.1 to 5.2. So far,
it went from RH 2.0.?? (some old 1995 release, I still have
a CD laying around) through all releases to 5.1 without a
hitch but this time I get an error message:

[normal kernel messages about TTY's and partition checks]

RAMDISK: Compressed image found at block 0
invalid compressed format (err=2)VFS: Cannot open root
device 08:22 Kernel panic: VFS: unable to mount root fs on
08:22

First I thought the boot floppy disk supplied in the boxed
set was bad but I made a copy of it beforehand and made
another attempt with that floppy with the same error. Then I
booted the system normally and dd'ed another boot disk from
5.2 CD images directory and again, it came up with the same
error. I have three systems to upgrade and luckily two of
them will boot off the CD. Still, my questions is:

What does the error mean? As I mentioned before, this is a
very generic perfectly functioning PC and always upgraded
easily.

I would much appreciate any insights.

Vlad

=====================================================

vlad@borg 23:29:26
 /home/vlad>$ mount
/dev/hdb1 on / type ext2 (rw)
/proc on /proc type proc (rw)
/dev/hdb2 on /usr type ext2 (ro)
/dev/hda3 on /usr/src type ext2 (rw)
/dev/hda4 on /usr/X11R6 type ext2 (rw)
/dev/hda1 on /var type ext2 (rw,nosuid)
/dev/hdb4 on /home type ext2 (rw,usrquota)
/dev/hda2 on /dos type vfat (ro,noexec)
/dev/hdd on /cd type iso9660 (ro)
klingon:/ on /klingon type nfs
(rw,nosuid,nodev,rsize=1024,wsize=1024,addr=10.0.0.1)

vlad@borg 23:29:28
 /home/vlad>$ ifconfig
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Bcast:127.255.255.255
Mask:255.0.0.0
          UP BROADCAST LOOPBACK RUNNING  MTU:3584  Metric:1
          RX packets:54 errors:0 dropped:0 overruns:0
          TX packets:54 errors:0 dropped:0 overruns:0

eth0      Link encap:Ethernet  HWaddr 00:10:4B:6F:48:A2
          inet addr:10.0.0.2  Bcast:10.255.255.255
Mask:255.0.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1767404 errors:0 dropped:0 overruns:0
          TX packets:1767601 errors:0 dropped:0 overruns:0
          Interrupt:9 Base address:0x6000

vlad@borg 23:30:04
 /home/vlad>$ df
Filesystem         1024-blocks  Used Available Capacity
Mounted on
/dev/hdb1             396165  300678    75027     80%   /
/dev/hdb2             603000  479233    92620     84%   /usr
/dev/hda3             199079  199073        6    100%
/usr/src
/dev/hda4             151259  115698    35561     76%
/usr/X11R6
/dev/hda1              79994   31936    48058     40%   /var
/dev/hdb4             163967  114016    41484     73%
/home
/dev/hda2             102598   11168    91430     11%   /dos
/dev/hdd              311634  311634        0    100%   /cd
klingon:/            1095993  641025   398341     62%
/klingon
/dev/sda4              96703      13    96690      0%
/zdrive

(although /ds is a vfat partition it does not have any
real bootable DOS installed and is used only for DOSEMU)

root@borg 23:32:05
 /root>#  hdparm -i /dev/hda

/dev/hda:

 Model=SAMSUNG SHD-30560A (APRO-5) SSI, FwRev=BF103S,
SerialNo=SS302300
 Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs }
 RawCHS=1086/16/63, TrkSize=37800, SectSize=600, ECCbytes=4
 BuffType=3(DualPortCache), BuffSize=126kB, MaxMultSect=16,
MultSect=off
 DblWordIO=no, maxPIO=1(medium), DMA=yes, maxDMA=2(fast)
 CurCHS=1087/16/63, CurSects=1095696, LBA=yes,
LBAsects=1096048
 tDMA={min:352,rec:352}, DMA modes: sword0 sword1 sword2
*mword0
 IORDY=yes, tPIO={min:352,w/IORDY:180}, PIO modes: mode3

root@borg 23:32:13
 /root>#  hdparm -i /dev/hdb

/dev/hdb:

 Model=QUANTUM FIREBALL1280A, FwRev=A63.0E00,
SerialNo=82260853
 Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs }
 RawCHS=2484/16/63, TrkSize=32256, SectSize=512, ECCbytes=4
 BuffType=3(DualPortCache), BuffSize=83kB, MaxMultSect=8,
MultSect=off
 DblWordIO=no, maxPIO=2(fast), DMA=yes, maxDMA=2(fast)
 CurCHS=2484/16/63, CurSects=2503872, LBA=yes,
LBAsects=2503872
 tDMA={min:120,rec:120}, DMA modes: sword0 sword1 sword2
mword0 mword1 *mword2
 IORDY=on/off, tPIO={min:333,w/IORDY:120}, PIO modes: mode3
mode4

root@borg 23:32:16
 /root># fdisk -l

Disk /dev/hda: 32 heads, 63 sectors, 543 cylinders
Units = cylinders of 2016 * 512 bytes

   Device Boot   Begin    Start      End   Blocks   Id
System
/dev/hda1            1        1       82    82624+  83
Linux native
/dev/hda2           83       83      184   102816    6  DOS
16-bit >=32M
/dev/hda3          185      185      388   205632   83
Linux native
/dev/hda4          389      389      543   156240   83
Linux native

Disk /dev/hdb: 64 heads, 63 sectors, 621 cylinders
Units = cylinders of 4032 * 512 bytes

   Device Boot   Begin    Start      End   Blocks   Id
System
/dev/hdb1            1        1      203   409216+  83
Linux native
/dev/hdb2          204      204      512   622944   83
Linux native
/dev/hdb3          513      513      537    50400   82
Linux swap
/dev/hdb4          538      538      621   169344   83
Linux native

Disk /dev/sda: 64 heads, 32 sectors, 96 cylinders
Units = cylinders of 2048 * 512 bytes

   Device Boot   Begin    Start      End   Blocks   Id
System
/dev/sda4   *        1        1       96    98288    83
Linux native

Please let me know if you need anything else.

Comment 1 David Lawrence 1998-12-02 18:29:59 UTC
This has been assigned to a developer for further review.

Comment 2 Matt Wilson 1998-12-09 15:34:59 UTC
Is this failing as you are booting off the boot floppy or upon reboot
after an upgrade?  If the problem is after the upgrade, it looks like
your /etc/lilo.conf may not have the root=/dev/hdb1 line in it.

What is your support ticket number?

Comment 3 Matt Wilson 1999-01-12 03:41:59 UTC
It really looks like a corrupt image or hardware problem.  No reply
since December 9.  Closing bug.


Note You need to log in before you can comment on or make changes to this bug.