Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2449 - typo in /usr/lib/rhs/rhs-printfilters/smbprint
Summary: typo in /usr/lib/rhs/rhs-printfilters/smbprint
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhs-printfilters
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
: 4808 5398 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-04-30 20:50 UTC by klmitch
Modified: 2008-05-01 15:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-03 15:09:35 UTC


Attachments (Terms of Use)

Description klmitch 1999-04-30 20:50:26 UTC
On the last line of /usr/lib/rhs/rhs-printfilters/smbprint,
the variable "$workgroupcmd" is misspelled "$wokrgroupcmd",
rendering smb printing non-functional.

Comment 1 Bill Nottingham 1999-05-03 15:09:59 UTC
Ugh.
fixed in rhs-printfilters-1.52-1, available in next rawhide.

Comment 2 Bill Nottingham 1999-08-31 17:41:59 UTC
*** Bug 4808 has been marked as a duplicate of this bug. ***

The last line ikn /usr/lib/rhs/rhs-printfilters/smbprint
contains:
   $wokrgroup
instead of
   $workgroup

This results in smbclient being run with an invalid command
line if a workgroup is specified in printtool, resulting in
no data being spooled.
Edit file as detailed above to fix problem.

Comment 3 Bill Nottingham 1999-09-27 18:22:59 UTC
*** Bug 5398 has been marked as a duplicate of this bug. ***

last line of /usr/lib/rhs/rhs-printfilters contains a typo.

the expression    $wokrgroupcmd   evaluates to null, should
read :            $workgroupcmd

This caused my smb print jobs to fail silently; smbclient
was denied access, and lpd saw the file dumped to /dev/null
successfully and so reported normal operation.  fixing the
typo makes everything wokr fine.  Am I the first person to
discover this ?


Note You need to log in before you can comment on or make changes to this bug.