Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 244077 - Yum silently ignores missing deps in a transaction
Summary: Yum silently ignores missing deps in a transaction
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 7
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: James Antill
QA Contact:
URL:
Whiteboard:
: 242268 243117 (view as bug list)
Depends On:
Blocks: 243433
TreeView+ depends on / blocked
 
Reported: 2007-06-13 17:09 UTC by Jesse Keating
Modified: 2014-01-21 22:58 UTC (History)
10 users (show)

Fixed In Version: 3.2.1-1.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-28 01:49:30 UTC


Attachments (Terms of Use)
Console log of yum ignoring dependencies (deleted)
2007-06-14 06:35 UTC, Ville Skyttä
no flags Details
yum update log (deleted)
2007-06-28 10:50 UTC, Kostas Georgiou
no flags Details

Description Jesse Keating 2007-06-13 17:09:14 UTC
It appears that yum is silently ignoring some deps in a transaction.  It may
have to do with Excludes being active, haven't found an easy reproducer for a
situation without.

Easy to reproduce with trying to localinstall a sourcerpm.  Just exclude one of
the deps that the source rpm would pull in.

yum localinstall syslinux-3.36-4.fc7.src.rpm will pull in 7 packages, including
nasm.

yum --exclude=nasm syslinux-3.36-4.fc7.src.rpm will happily pull in 6 packages,
/not/ including nasm.  There is no log or failure on being able to resolve the
nasm dep.  This effects mock in some obvious ways (:

Comment 1 Jesse Keating 2007-06-13 17:30:50 UTC
*** Bug 243117 has been marked as a duplicate of this bug. ***

Comment 2 Jeremy Katz 2007-06-13 17:54:06 UTC
Thanks for the easy reproducer.  Fixed in upstream CVS.  Will work on getting a
3.2.1 out soon so that we can push everywhere as there are a few other
similar/related fixes that we should also get.

Comment 3 Ville Skyttä 2007-06-14 06:35:49 UTC
Created attachment 156959 [details]
Console log of yum ignoring dependencies

yum just did this for me too, no excludes involved.

Full log attached - note that the new update kernel requires mkinitrd >=
6.0.9-7.1, but no such version is in the F7 updates repo (it's only in
updates-testing right now).

updates-testing is not enabled in my yum config, but I have occasionally
enabled it on the cli to test something so I do have some old metadata files
for it present.

Another bug visible in the log is that yum removed kernel 2.6.21-1.3194.fc7,
but kmod-nvidia had a dependency on it.  After the install transaction, that
kernel is gone but the kmod-nvidia package requiring it is still present, now
with broken deps.

Comment 4 Jeremy Katz 2007-06-14 19:50:20 UTC
Yeah, excludes aren't the only trigger -- just an easy one.  Basically, missing
deps get noticed on the first run but not later because we cache the fact that
we already solved the deps for the package.  Even if they weren't solved (oops). 

Comment 5 Mamoru TASAKA 2007-06-19 16:47:18 UTC
Is the phenomenon I noticed (as below) related to this?

-------------------------------------------------------------------
[root@localhost i386]# rpm -q gtksourceview gtksourceview-devel
gtksourceview-1.8.5-1.fc7
gtksourceview-devel-1.8.5-1.fc7
[root@localhost i386]# LANG=C rpm -e --test gtksourceview
error: Failed dependencies:
        libgtksourceview-1.0.so.0 is needed by (installed) gedit-2.18.1-1.fc8.i386
        libgtksourceview-1.0.so.0 is needed by (installed)
gnome-python2-gtksourceview-2.18.0-4.fc8.i386
        libgtksourceview-1.0.so.0 is needed by (installed)
libgtksourceviewmm-0.3.1-1.fc8.i386
        libgtksourceview-1.0.so.0 is needed by (installed)
gtksourceview-devel-1.8.5-1.fc7.i386
        gtksourceview >= 1.1.90 is needed by (installed)
gnome-python2-gtksourceview-2.18.0-4.fc8.i386
        gtksourceview = 1.8.5-1.fc7 is needed by (installed)
gtksourceview-devel-1.8.5-1.fc7.i386
[root@localhost i386]# rpm -qp --provides gtksourceview-1.90.1-1.fc8.i386.rpm |
grep libgtk
libgtksourceview-2.0.so.0  
[root@localhost i386]# yum upgrade gtksourceview
Loading "installonlyn" plugin
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package gtksourceview.i386 0:1.90.1-1.fc8 set to be updated
--> Processing Dependency: libgtksourceview-1.0.so.0 for package:
gtksourceview-devel
--> Processing Dependency: libgtksourceview-1.0.so.0 for package: gedit
--> Processing Dependency: libgtksourceview-1.0.so.0 for package:
gnome-python2-gtksourceview
--> Processing Dependency: libgtksourceview-1.0.so.0 for package: libgtksourceviewmm
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 gtksourceview           i386       1.90.1-1.fc8     development       617 k

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total download size: 617 k
Is this ok [y/N]: N
Exiting on user Command
Complete!
[root@localhost i386]# rpm -q yum
yum-3.2.0-1.fc7
------------------------------------------------------------------------

Comment 6 Jesse Keating 2007-06-21 14:22:14 UTC
Yes, that seems like the same issue.

Comment 7 Fedora Update System 2007-06-21 22:03:43 UTC
yum-3.2.1-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2007-06-28 01:48:50 UTC
yum-3.2.1-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Kostas Georgiou 2007-06-28 10:50:37 UTC
Created attachment 158108 [details]
yum update log

This doesn't look sane to me, for some reason yum decided to install the i386
version of the libraries. Not sure if it is related to the fix though.

Comment 10 Kostas Georgiou 2007-06-28 12:43:49 UTC
The above problem is unrelated so it moved to #246078.

Comment 11 Jeremy Katz 2007-09-13 15:21:05 UTC
*** Bug 242268 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.