Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 243555 - utrace: Failing PTRACE_DETACH after ATTACH+CONT(SIGSTOP)
Summary: utrace: Failing PTRACE_DETACH after ATTACH+CONT(SIGSTOP)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
: ---
Assignee: Roland McGrath
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On: 244162
Blocks: 233852 233853
TreeView+ depends on / blocked
 
Reported: 2007-06-09 17:34 UTC by Jan Kratochvil
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version: RHBA-2007-0959
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-07 19:52:15 UTC
Target Upstream Version:


Attachments (Terms of Use)
Testcase (deleted)
2007-06-09 17:34 UTC, Jan Kratochvil
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0959 normal SHIPPED_LIVE Updated kernel packages for Red Hat Enterprise Linux 5 Update 1 2007-11-08 00:47:37 UTC

Description Jan Kratochvil 2007-06-09 17:34:21 UTC
Description of problem:
Developed on upstream the minimal raceless PTRACE_ATTACH method.
It unfortunately fails on UTRACE, I hope it is not a race.

Version-Release number of selected component (if applicable):
kernel-2.6.18-8.1.1.el5.x86_64
kernel-2.6.21-1.3194.fc7
kernel-2.6.20-1.2948.fc6.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. gcc -o cont-sigstop-detach cont-sigstop-detach.c -ggdb2 -Wall
2. ./cont-sigstop-detach 

Actual results:
utrace bug hit
Aborted

Expected results:
[endless run on the upstream linux-2.6.20.4.x86_64]

Additional info:
The code does:
PTRACE_ATTACH
PTRACE_CONT(SIGSTOP)
waitpid() -> SIGSTOP
PTRACE_DETACH -> upstream: 0 vs. utrace: ESRCH

The Bug should be cloned for Fedora if you consider it valid.

Comment 1 Jan Kratochvil 2007-06-09 17:34:21 UTC
Created attachment 156655 [details]
Testcase

Comment 2 Roland McGrath 2007-06-14 09:11:06 UTC
This is a regression and will be fixed in the 5.1 utrace update.

Comment 3 RHEL Product and Program Management 2007-06-14 09:24:45 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 4 RHEL Product and Program Management 2007-06-14 09:28:45 UTC
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.

Comment 6 RHEL Product and Program Management 2007-06-20 12:31:19 UTC
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.

Comment 9 Don Zickus 2007-07-19 21:21:30 UTC
in kernel-2.6.18-30.el5

Comment 11 Mike Gahagan 2007-08-03 21:07:19 UTC
verified that the testcase does not abort with the -37 kernel. 



Comment 12 Jan Kratochvil 2007-09-27 18:38:51 UTC
On kernel-2.6.18-48.el5.x86_64 the testcase from Comment #1 hangs on line 105
(not the original goal of this testcase).
Did not find the other specific utrace Bug affecting it.


Comment 14 Jan Kratochvil 2007-10-28 21:03:25 UTC
Comment on attachment 156655 [details]
Testcase

Testcase had some racy assertion failures.
Updated testcase is at:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/~checkout~/tests/ptrace-tests/test
s/ptrace-cont-sigstop-detach.c?cvsroot=systemtap
from the testsuite
http://sourceware.org/systemtap/wiki/utrace/tests
It has been verified as FAILing on: kernel-xen-2.6.18-8.1.14.el5.x86_64

Comment 15 errata-xmlrpc 2007-11-07 19:52:15 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html



Note You need to log in before you can comment on or make changes to this bug.