Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 243069 - xterm installed setgid; environment whacked
Summary: xterm installed setgid; environment whacked
Keywords:
Status: CLOSED DUPLICATE of bug 229360
Alias: None
Product: Fedora
Classification: Fedora
Component: xterm
Version: 7
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-07 06:45 UTC by Peter TB Brett
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-07 14:51:05 UTC


Attachments (Terms of Use)

Description Peter TB Brett 2007-06-07 06:45:27 UTC
Description of problem:

xterm is installed setgid utempter.  This means that any LD_CONFIG_PATH set in 
a user's .profile or .bash_profile is destroyed.

Version-Release number of selected component (if applicable):

xterm-225-2.fc7

How reproducible:

Add LD_LIBRARY_PATH=/some/path to .profile.  Exec xterm from a login shell.  
Check environment.

Steps to Reproduce:

1.

$ tail -n2 .profile
export LD_LIBRARY_PATH=/home/peter/opt/lib:$LD_LIBRARY_PATH
export LD_TEST=/foo/bar

2.

$ (exec -l /bin/sh -c "env | grep LD")
LD_LIBRARY_PATH=/home/peter/opt/lib:
LD_TEST=/foo/bar

3.

$ (exec -l /bin/sh -c "exec xterm -geometry 80x24-0-0")


4. In new xterm window:

$ env | grep LD
LD_TEST=/foo/bar




Additional info:

In F7, this also affects Konsole.

Comment 1 Peter TB Brett 2007-06-07 07:00:00 UTC
This is related to Bug 164869.

Comment 2 Miroslav Lichvar 2007-06-07 14:51:05 UTC
xterm has to have utempter setgid since directory where the utempter binary is
located is accessible only to group utempter.

*** This bug has been marked as a duplicate of 229360 ***


Note You need to log in before you can comment on or make changes to this bug.