Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 241892 - gnome-libs fails to build on ppc64
Summary: gnome-libs fails to build on ppc64
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-libs
Version: rawhide
Hardware: ppc64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Paul Howarth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: FE-ExcludeArch-ppc64, F-ExcludeArch-ppc64 241910
TreeView+ depends on / blocked
 
Reported: 2007-05-31 14:50 UTC by Paul Howarth
Modified: 2008-01-23 18:32 UTC (History)
0 users

Fixed In Version: 1.4.2-7.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-01-23 18:32:57 UTC


Attachments (Terms of Use)

Description Paul Howarth 2007-05-31 14:50:06 UTC
Failure is as follows:

Making all in libgnome
make[2]: Entering directory `/builddir/build/BUILD/gnome-libs-1.4.2/libgnome'
/usr/bin/libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I./..
-DNEED_GNOMESUPPORT_H -I../support -I../support -I../intl -I../intl
-I/usr/include/glib-1.2 -I/usr/lib64/glib/include -I/usr/include/gtk-1.2
-I/usr/include/glib-1.2 -I/usr/lib64/glib/include  
-DGNOMELIBDIR=\""/usr/lib64"\" -DGNOMEDATADIR=\""/usr/share"\"
-DGNOMEBINDIR=\""/usr/bin"\" -DGNOMELOCALSTATEDIR=\""/var"\"
-DGNOMELOCALEDIR=\""/usr/share/locale"\" -DGNOMESYSCONFDIR=\""/etc"\"
-DVERSION=\""1.4.2"\" -DG_LOG_DOMAIN=\"Gnome\"  -I/usr/include/libpng10  
-I/builddir/build/BUILD/gnome-libs-1.4.2/db.1.85/include -I/usr/include/gtk-1.2
-I/usr/include/glib-1.2 -I/usr/lib64/glib/include
-I/builddir/build/BUILD/gnome-libs-1.4.2/db.1.85/include
-I/builddir/build/BUILD/gnome-libs-1.4.2/db.1.85/include  -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m64 -mminimal-toc -I/usr/include/libpng10   -Wall -Wunused  -c gnome-config.c
mkdir .libs
 gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I./.. -DNEED_GNOMESUPPORT_H -I../support
-I../support -I../intl -I../intl -I/usr/include/glib-1.2
-I/usr/lib64/glib/include -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2
-I/usr/lib64/glib/include -DGNOMELIBDIR=\"/usr/lib64\"
-DGNOMEDATADIR=\"/usr/share\" -DGNOMEBINDIR=\"/usr/bin\"
-DGNOMELOCALSTATEDIR=\"/var\" -DGNOMELOCALEDIR=\"/usr/share/locale\"
-DGNOMESYSCONFDIR=\"/etc\" -DVERSION=\"1.4.2\" -DG_LOG_DOMAIN=\"Gnome\"
-I/usr/include/libpng10 -I/builddir/build/BUILD/gnome-libs-1.4.2/db.1.85/include
-I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib64/glib/include
-I/builddir/build/BUILD/gnome-libs-1.4.2/db.1.85/include
-I/builddir/build/BUILD/gnome-libs-1.4.2/db.1.85/include -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m64 -mminimal-toc -I/usr/include/libpng10 -Wall -Wunused
-Wp,-MD,.deps/gnome-config.pp -c gnome-config.c  -fPIC -DPIC -o .libs/gnome-config.o
 gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I./.. -DNEED_GNOMESUPPORT_H -I../support
-I../support -I../intl -I../intl -I/usr/include/glib-1.2
-I/usr/lib64/glib/include -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2
-I/usr/lib64/glib/include -DGNOMELIBDIR=\"/usr/lib64\"
-DGNOMEDATADIR=\"/usr/share\" -DGNOMEBINDIR=\"/usr/bin\"
-DGNOMELOCALSTATEDIR=\"/var\" -DGNOMELOCALEDIR=\"/usr/share/locale\"
-DGNOMESYSCONFDIR=\"/etc\" -DVERSION=\"1.4.2\" -DG_LOG_DOMAIN=\"Gnome\"
-I/usr/include/libpng10 -I/builddir/build/BUILD/gnome-libs-1.4.2/db.1.85/include
-I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib64/glib/include
-I/builddir/build/BUILD/gnome-libs-1.4.2/db.1.85/include
-I/builddir/build/BUILD/gnome-libs-1.4.2/db.1.85/include -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m64 -mminimal-toc -I/usr/include/libpng10 -Wall -Wunused
-Wp,-MD,.deps/gnome-config.pp -c gnome-config.c -o gnome-config.o >/dev/null 2>&1
/usr/bin/libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I./..
-DNEED_GNOMESUPPORT_H -I../support -I../support -I../intl -I../intl
-I/usr/include/glib-1.2 -I/usr/lib64/glib/include -I/usr/include/gtk-1.2
-I/usr/include/glib-1.2 -I/usr/lib64/glib/include  
-DGNOMELIBDIR=\""/usr/lib64"\" -DGNOMEDATADIR=\""/usr/share"\"
-DGNOMEBINDIR=\""/usr/bin"\" -DGNOMELOCALSTATEDIR=\""/var"\"
-DGNOMELOCALEDIR=\""/usr/share/locale"\" -DGNOMESYSCONFDIR=\""/etc"\"
-DVERSION=\""1.4.2"\" -DG_LOG_DOMAIN=\"Gnome\"  -I/usr/include/libpng10  
-I/builddir/build/BUILD/gnome-libs-1.4.2/db.1.85/include -I/usr/include/gtk-1.2
-I/usr/include/glib-1.2 -I/usr/lib64/glib/include
-I/builddir/build/BUILD/gnome-libs-1.4.2/db.1.85/include
-I/builddir/build/BUILD/gnome-libs-1.4.2/db.1.85/include  -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m64 -mminimal-toc -I/usr/include/libpng10   -Wall -Wunused  -c gnome-dentry.c
 gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I./.. -DNEED_GNOMESUPPORT_H -I../support
-I../support -I../intl -I../intl -I/usr/include/glib-1.2
-I/usr/lib64/glib/include -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2
-I/usr/lib64/glib/include -DGNOMELIBDIR=\"/usr/lib64\"
-DGNOMEDATADIR=\"/usr/share\" -DGNOMEBINDIR=\"/usr/bin\"
-DGNOMELOCALSTATEDIR=\"/var\" -DGNOMELOCALEDIR=\"/usr/share/locale\"
-DGNOMESYSCONFDIR=\"/etc\" -DVERSION=\"1.4.2\" -DG_LOG_DOMAIN=\"Gnome\"
-I/usr/include/libpng10 -I/builddir/build/BUILD/gnome-libs-1.4.2/db.1.85/include
-I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib64/glib/include
-I/builddir/build/BUILD/gnome-libs-1.4.2/db.1.85/include
-I/builddir/build/BUILD/gnome-libs-1.4.2/db.1.85/include -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m64 -mminimal-toc -I/usr/include/libpng10 -Wall -Wunused
-Wp,-MD,.deps/gnome-dentry.pp -c gnome-dentry.c  -fPIC -DPIC -o .libs/gnome-dentry.o
gnome-dentry.c: In function 'g_file_get_contents':
gnome-dentry.c:956: warning: passing argument 5 of 'get_contents_regfile' from
incompatible pointer type
 gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I./.. -DNEED_GNOMESUPPORT_H -I../support
-I../support -I../intl -I../intl -I/usr/include/glib-1.2
-I/usr/lib64/glib/include -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2
-I/usr/lib64/glib/include -DGNOMELIBDIR=\"/usr/lib64\"
-DGNOMEDATADIR=\"/usr/share\" -DGNOMEBINDIR=\"/usr/bin\"
-DGNOMELOCALSTATEDIR=\"/var\" -DGNOMELOCALEDIR=\"/usr/share/locale\"
-DGNOMESYSCONFDIR=\"/etc\" -DVERSION=\"1.4.2\" -DG_LOG_DOMAIN=\"Gnome\"
-I/usr/include/libpng10 -I/builddir/build/BUILD/gnome-libs-1.4.2/db.1.85/include
-I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib64/glib/include
-I/builddir/build/BUILD/gnome-libs-1.4.2/db.1.85/include
-I/builddir/build/BUILD/gnome-libs-1.4.2/db.1.85/include -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m64 -mminimal-toc -I/usr/include/libpng10 -Wall -Wunused
-Wp,-MD,.deps/gnome-dentry.pp -c gnome-dentry.c -o gnome-dentry.o >/dev/null 2>&1
/usr/bin/libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I./..
-DNEED_GNOMESUPPORT_H -I../support -I../support -I../intl -I../intl
-I/usr/include/glib-1.2 -I/usr/lib64/glib/include -I/usr/include/gtk-1.2
-I/usr/include/glib-1.2 -I/usr/lib64/glib/include  
-DGNOMELIBDIR=\""/usr/lib64"\" -DGNOMEDATADIR=\""/usr/share"\"
-DGNOMEBINDIR=\""/usr/bin"\" -DGNOMELOCALSTATEDIR=\""/var"\"
-DGNOMELOCALEDIR=\""/usr/share/locale"\" -DGNOMESYSCONFDIR=\""/etc"\"
-DVERSION=\""1.4.2"\" -DG_LOG_DOMAIN=\"Gnome\"  -I/usr/include/libpng10  
-I/builddir/build/BUILD/gnome-libs-1.4.2/db.1.85/include -I/usr/include/gtk-1.2
-I/usr/include/glib-1.2 -I/usr/lib64/glib/include
-I/builddir/build/BUILD/gnome-libs-1.4.2/db.1.85/include
-I/builddir/build/BUILD/gnome-libs-1.4.2/db.1.85/include  -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m64 -mminimal-toc -I/usr/include/libpng10   -Wall -Wunused  -c gnome-exec.c
 gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I./.. -DNEED_GNOMESUPPORT_H -I../support
-I../support -I../intl -I../intl -I/usr/include/glib-1.2
-I/usr/lib64/glib/include -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2
-I/usr/lib64/glib/include -DGNOMELIBDIR=\"/usr/lib64\"
-DGNOMEDATADIR=\"/usr/share\" -DGNOMEBINDIR=\"/usr/bin\"
-DGNOMELOCALSTATEDIR=\"/var\" -DGNOMELOCALEDIR=\"/usr/share/locale\"
-DGNOMESYSCONFDIR=\"/etc\" -DVERSION=\"1.4.2\" -DG_LOG_DOMAIN=\"Gnome\"
-I/usr/include/libpng10 -I/builddir/build/BUILD/gnome-libs-1.4.2/db.1.85/include
-I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib64/glib/include
-I/builddir/build/BUILD/gnome-libs-1.4.2/db.1.85/include
-I/builddir/build/BUILD/gnome-libs-1.4.2/db.1.85/include -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m64 -mminimal-toc -I/usr/include/libpng10 -Wall -Wunused
-Wp,-MD,.deps/gnome-exec.pp -c gnome-exec.c  -fPIC -DPIC -o .libs/gnome-exec.o
In file included from /usr/include/asm/elf.h:5,
                 from /usr/include/asm/sigcontext.h:12,
                 from /usr/include/bits/sigcontext.h:28,
                 from /usr/include/signal.h:333,
                 from /usr/include/sys/wait.h:31,
                 from gnome-exec.c:48:
/usr/include/asm/types.h:20: error: two or more data types in declaration specifiers
gnome-exec.c: In function 'gnome_execute_async_with_env_fds':
gnome-exec.c:193: warning: format '%d' expects type 'int', but argument 5 has
type 'long unsigned int'
gnome-exec.c:113: warning: ignoring return value of 'write', declared with
attribute warn_unused_result
gnome-exec.c:114: warning: ignoring return value of 'write', declared with
attribute warn_unused_result
gnome-exec.c:125: warning: ignoring return value of 'write', declared with
attribute warn_unused_result
gnome-exec.c:144: warning: ignoring return value of 'chdir', declared with
attribute warn_unused_result
gnome-exec.c:178: warning: ignoring return value of 'write', declared with
attribute warn_unused_result

Full build log available here:
http://people.redhat.com/notting/ppc64-rebuild/gnome-libs-1.4.2-5.fc7/build.log

Seems to be some sort of weirdness/interaction with standard include files;
can't diagnose any further as I have no access to a ppc64 box. Other primary
architectures seem OK.

Comment 1 Paul Howarth 2008-01-23 18:32:57 UTC
The problem was caused by the configure script's inability to find umode_t on
ppc64. Adding an include of <signal.h> is sufficient, in a roundabout way, for
the type to be found and the build to succeed.


Note You need to log in before you can comment on or make changes to this bug.