Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 241714 - 64bit Xen DomU goes 100% CPU busy
Summary: 64bit Xen DomU goes 100% CPU busy
Keywords:
Status: CLOSED DUPLICATE of bug 234160
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen
Version: 5.0
Hardware: x86_64
OS: Linux
urgent
high
Target Milestone: ---
: ---
Assignee: Xen Maintainance List
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-29 18:40 UTC by andy prowse
Modified: 2008-01-08 13:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-07-05 11:51:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
xen logs -- wrong logs -- PLEASE DELETE (deleted)
2007-06-27 13:53 UTC, andy prowse
no flags Details
xen logs - 64 bit (deleted)
2007-06-27 14:06 UTC, andy prowse
no flags Details

Description andy prowse 2007-05-29 18:40:19 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:

Running either hts or applying updates causes DomU to go 100% CPU busy and the
console is unresponsive.

Steps to Reproduce:
1. Create 64 bit Xen guest (i.e. use steps from hts)
2. Run hts certify, or yum -y update
3. DomU will become 100% CPU bust and unresponsive
  
Actual results:

DomU will become 100% CPU bust and unresponsive

Expected results:

Completion of tests/updates.

Additional info:

System works OK in 32 bit testing.

H/W Fujitsu S7110 Notebook
2 GB and 4 GB RAM tested
Intel T7200 Core 2 Duo

Comment 2 andy prowse 2007-05-30 10:51:12 UTC
Reran certification test on notebook.  DomU froze after 15 minutes.

I had an iostat and top running in terminals, and both stopped responding. No
useful information on either.

No messages in /var/log/messages

I will be happy to run any monitor script that you provide.

Comment 4 andy prowse 2007-06-27 12:10:24 UTC
Performing hardware cert on another Fujitsu notebook, the E8410:

T7300 Intel Core 2 Duo
VT enabled
1GB-4GB RAM

Same issue, DomU freezes during certification with CPU at 100% busy 

32 bit OK, 64 bit freezes.

System was updated to latest available updates  on 26JUN07

Comment 5 andy prowse 2007-06-27 13:53:17 UTC
Created attachment 158008 [details]
xen logs -- wrong logs -- PLEASE DELETE

Here is a tgz containing the xen logs, the DomU guest always froze/hung

Comment 6 andy prowse 2007-06-27 14:01:00 UTC
Wron logs, 

PLEASE DELETE

Comment 7 andy prowse 2007-06-27 14:06:30 UTC
Created attachment 158014 [details]
xen logs - 64 bit

Here are the xen logs from the failed attempts at h/w certification under RHEL5
64 bit.

Comment 8 Chris Lalancette 2007-07-03 14:09:14 UTC
I believe that you are attempting to use a RHEL-5 Fully virtualized guest; is
that correct?  If so, I think this is the same issue as BZ 234160.  In that
case, this issue should be fixed by 5.1.  Can you please confirm that this is
indeed what you are attempting?

Thanks,
Chris Lalancette

Comment 9 andy prowse 2007-07-05 04:39:47 UTC
Yes, my issue appears to be a duplicate of 234160.

Comment 10 Chris Lalancette 2007-07-05 11:51:11 UTC
OK, thanks for clarifying.  I'm going to close this out as a duplicate of that bug.

Chris Lalancette

*** This bug has been marked as a duplicate of 234160 ***

Comment 11 Larry Troan 2007-07-31 11:54:21 UTC
Using the RHEL5.1 beta, Andy Prowse reports.....
On Mon, 2007-07-30 at 20:52 -0400, Andy Prowse wrote:
Hi Larry,
> 
> I have had the 64 bit DomU up for 8 hours so far, and have run the hts
> test in it OK.  Looks like the issue I was experiencing with RHEL5
> x86_64 is fixed.


Note You need to log in before you can comment on or make changes to this bug.