Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2415 - Still no bzip2 support in version of GNU tar included with Red Hat 6.0
Summary: Still no bzip2 support in version of GNU tar included with Red Hat 6.0
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tar
Version: 6.0
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
: 3668 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-04-29 14:20 UTC by dripton
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-13 00:25:32 UTC


Attachments (Terms of Use)

Description dripton 1999-04-29 14:20:25 UTC
As you probably know, bzip2 compresses significantly better
than gzip, and so is starting to supplant it just as gzip
replaced compress.

GNU tar 1.12 supports gzip (with the z option), but does not
support bzip2.  Making it also support bzip2 (with the
analagous y option) is trivial (there are a dozen
independent versions of the patch floating around the web)
and very useful.  Many of us have to reapply this patch
every time we install Red Hat.  It would be save a lot of
work if Red Hat would apply it once to their tar rpm.  The
easier it is for everyone to use bzip2, the more bandwidth
we all save.

Comment 1 Jeff Johnson 1999-05-01 17:42:59 UTC
Can someone supply a reasonable patch (or pointer) for bzip2
support in tar?

Comment 2 dripton 1999-05-04 16:00:59 UTC
Here's one version of the patch.  It's in the mini-HOWTO, so it's
probably the most used.

http://www.linuxhq.com/HOWTO/mini/Bzip2-4.html

Comment 3 Jeff Johnson 1999-06-15 18:35:59 UTC
Fixed (by upgrading) in tar-1.12-10.64011. Thanks for the pointer.

Comment 4 Jeff Johnson 1999-06-20 16:19:59 UTC
Reopened because tar-1.12-64013 does not support bzip2 and the
maintainer does not wish to include bzip2 support using -y.

Comment 5 Jeff Johnson 1999-06-23 14:25:59 UTC
*** Bug 3668 has been marked as a duplicate of this bug. ***

Red Hat Linux still ships with no bzip2 support (by
default).  This is a major annoyance to those of us with
slow connections and who prefer to download the smaller
tarballs, and a "bug" that's so easy to fix -- just add the
bzip2 package as one of the default components and compile
tar with bzip2 support built in.

Comment 6 Bill Nottingham 1999-07-13 22:00:59 UTC
You can use the --use option to specify a compression
program...

Comment 7 Jeff Johnson 1999-08-13 00:25:59 UTC
Fixed (again) in tar-1.13.6-1.

Comment 8 Brock Organ 1999-09-10 19:52:59 UTC
QA testing for tar-1.13.11-1.i386.rpm: (lorax)

I am able to use bzip2 to create and extract archive:
# tar cf foo.tar.bzip2 --bzip2 foo
# tar xf foo.tar.bzip2 --bzip2


Note You need to log in before you can comment on or make changes to this bug.