Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 241491 (atix1400) - Fedora 7 RC2 no X with ati x1400
Summary: Fedora 7 RC2 no X with ati x1400
Keywords:
Status: CLOSED ERRATA
Alias: atix1400
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-vesa
Version: 7
Hardware: All
OS: Linux
medium
urgent
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
: 231006 240591 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-26 17:54 UTC by Justin Conover
Modified: 2007-11-30 22:12 UTC (History)
3 users (show)

Fixed In Version: 1.3.0-8.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-07 15:58:55 UTC


Attachments (Terms of Use)
xorg.conf (deleted)
2007-05-26 17:54 UTC, Justin Conover
no flags Details
Xorg.0.log (deleted)
2007-05-26 17:54 UTC, Justin Conover
no flags Details
Xorg.setup.log (deleted)
2007-05-26 17:55 UTC, Justin Conover
no flags Details

Description Justin Conover 2007-05-26 17:54:02 UTC
Description of problem:
Booting the latest rawhide live dvd Fedora-7-Live-x86_64-RC2, leaves me with no X

Version-Release number of selected component (if applicable):


How reproducible:
Boot cd DVD

Steps to Reproduce:
1. Boot the DVD, no X
2.
3.
  
Actual results:


Expected results:


Additional info:  Some xorg.log's

Comment 1 Justin Conover 2007-05-26 17:54:02 UTC
Created attachment 155500 [details]
xorg.conf

Comment 2 Justin Conover 2007-05-26 17:54:37 UTC
Created attachment 155501 [details]
Xorg.0.log

Comment 3 Justin Conover 2007-05-26 17:55:56 UTC
Created attachment 155502 [details]
Xorg.setup.log

It allowed me to do a system-config-display and see the visual tool, but after
startx it bailed again.

Comment 4 Justin Conover 2007-06-01 00:15:34 UTC
Samething happens with F7 but I have a fix for it, go back to the old package
that last worked, thanks to koji!

Alright I got it working again with the old vesa package.....

Fresh install of F7 live cd fails.

Once, X bails 6 times or more and you can login with root (no passwd):

# init 3

Add a mode line of 800x600 to xorg.conf

# vi /etc/X11/xorg.conf

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes     "800x600"
        EndSubSection
EndSection

# init 5

Get a terminal

# yum install wget
# wget
http://koji.fedoraproject.org/packages/xorg-x11-drv-vesa/1.3.0/5.fc7/i386/xorg-x11-drv-vesa-1.3.0-5.fc7.i386.rpm

# rpm -Uvh --oldpackage xorg-x11-drv-vesa-1.3.0-5.fc7.i386.rpm


http://koji.fedoraproject.org/koji/buildinfo?buildID=6413

What was the reason for adding the sync range hack?

* Wed May 09 2007 Adam Jackson <ajax@redhat.com> 1.3.0-6
- Re-add the sync range hack. (#235066)

* Tue Mar 20 2007 Adam Jackson <
ajax@redhat.com> 1.3.0-5
- vesa-1.3.0-mode-heuristics.patch: If strict intersection of VBE and EDID
  modes leaves no modes remaining after validation, try again with just

  range and VBE checks.  Replaces earlier range-hack and validmode patches.

Comment 5 Adam D. Ligas 2007-06-04 04:19:17 UTC
I've got the same issue on my brother's Dell Inspirion E1505 laptop with ATI
X1400 video.  I can also verify that installing the older xorg vesa driver
restores functionality.

Comment 6 Adam Jackson 2007-06-04 15:34:17 UTC
*** Bug 240591 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2007-06-06 16:40:58 UTC
xorg-x11-drv-vesa-1.3.0-8.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2007-06-07 15:58:52 UTC
xorg-x11-drv-vesa-1.3.0-8.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Justin Conover 2007-06-08 04:31:56 UTC
1.3.0-8 works for me.

Thanks ajax!

Comment 10 Adam Jackson 2007-06-14 16:12:17 UTC
*** Bug 231006 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.