Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 240591 - X server crash (VESA)
Summary: X server crash (VESA)
Keywords:
Status: CLOSED DUPLICATE of bug 241491
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-vesa
Version: rawhide
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-18 16:44 UTC by Onno Witvliet
Modified: 2018-04-11 17:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-04 15:34:14 UTC


Attachments (Terms of Use)
Xorg.0.log (deleted)
2007-05-18 16:44 UTC, Onno Witvliet
no flags Details
xorg.conf file (deleted)
2007-05-18 16:45 UTC, Onno Witvliet
no flags Details
Xorg.0.log with glibc version 2.5.90-21 (deleted)
2007-05-23 18:03 UTC, Onno Witvliet
no flags Details

Description Onno Witvliet 2007-05-18 16:44:42 UTC
Description of problem:

I'm running Fedora 7T4 (on a HP Compaq nc8430). After the latest batch of yum
development updates, my X server crashes on startup with the following backtrace:

Backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x6d) [0x47f5ed]
1: /lib64/libc.so.6 [0x2aaaab17f620]
2: /usr/lib64/xorg/modules/drivers//vesa_drv.so [0x2aaaac81c2c1]
3: /usr/bin/Xorg(InitOutput+0x9ad) [0x46320d]
4: /usr/bin/Xorg(main+0x275) [0x433e65]
5: /lib64/libc.so.6(__libc_start_main+0xf4) [0x2aaaab16caa4]
6: /usr/bin/Xorg(FontFileCompleteXLFD+0x231) [0x433319]

Fatal server error:
Caught signal 11.  Server aborting

Additional info:
The machine has an ATI Radeon Mobility x1600 video card.

X server worked with the f7t4 release software

Comment 1 Onno Witvliet 2007-05-18 16:44:42 UTC
Created attachment 155013 [details]
Xorg.0.log

Comment 2 Onno Witvliet 2007-05-18 16:45:43 UTC
Created attachment 155014 [details]
xorg.conf file

Comment 3 Onno Witvliet 2007-05-23 18:03:04 UTC
Created attachment 155282 [details]
Xorg.0.log with glibc version 2.5.90-21

I've downgraded the glibc to the original F7T4 version (2.5.90-21). The X
server no longer crashes, but just stops with:

FreeFontPath: FPE "unix/:7100" refcount is 2, should be 1; fixing


I hope this helps

Comment 4 Matěj Cepl 2007-05-26 14:53:35 UTC
Probably DUP of bug 231006 ? There is something screwed up about this card. We
will investigate.

Comment 5 Adam Jackson 2007-05-26 18:26:58 UTC
Yeah, think it is a dup.  Really wish I knew how to reproduce this.

*** This bug has been marked as a duplicate of 231006 ***

Comment 6 Adam Jackson 2007-05-26 18:28:23 UTC
On second thought, no.

Comment 7 Adam Jackson 2007-06-04 15:34:14 UTC

*** This bug has been marked as a duplicate of 241491 ***


Note You need to log in before you can comment on or make changes to this bug.