Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2404 - xterm/nxterm and readline are unhappy together
Summary: xterm/nxterm and readline are unhappy together
Keywords:
Status: CLOSED DUPLICATE of bug 2738
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: distribution
Version: 6.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-04-29 00:00 UTC by hermes
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-15 22:28:08 UTC


Attachments (Terms of Use)

Description hermes 1999-04-29 00:00:41 UTC
I just installed RH6.0, upgrading from a 5.2 system, and
I am finding that I cannot use the meta key to perform
Emacs-style editing operations from within bash or ncftp,
both of which use termcap.  This worked fine in the latest
XFree86 package update released for 5.2, so I assume that
something has changed in termcap for 6.0.

Oddly enough, I can use the meta key as before when running
either rxvt or the GNOME terminal program, which suggests
the termcap entry for xterm having changed.  However, tcsh
gets the meta key stuff right in an xterm window, and it
uses termcap directly, without going through readline.

Backing out the RH6.0 readline RPM and installing the 5.2
RPM makes no difference, so I doubt readline is the problem.

I use the meta keys all the time in both bash and ncftp, so
it's very confusing to have them misbehave.

Comment 1 Jeff Johnson 1999-05-15 22:28:59 UTC
*** This bug has been marked as a duplicate of 2738 ***


Note You need to log in before you can comment on or make changes to this bug.