Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 240335 - up2date traceback
Summary: up2date traceback
Keywords:
Status: CLOSED DUPLICATE of bug 235140
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date
Version: 4.5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Pradeep Kilambi
QA Contact: Beth Nackashi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-16 16:16 UTC by Dennis Gregorovic
Modified: 2007-11-17 01:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-16 16:30:22 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Dennis Gregorovic 2007-05-16 16:16:52 UTC
# up2date ant

Fetching Obsoletes list for channel: rhel-ppc-as-4...
Fetching Obsoletes list for channel: rhel-ppc-as-4-extras...
Fetching Obsoletes list for channel: rhel-4-as-ppc-rhaps-2...
Fetching Obsoletes list for channel: rhel-4-as-ppc-rhds-3...

Fetching rpm headers...
########################################

Name                                    Version        Rel
----------------------------------------------------------
ant                                     1.6.5          1jpp_3rh          noarch


Testing package set / solving RPM inter-dependencies...
An error has occurred:
exceptions.UnboundLocalError
See /var/log/up2date for more information

# rpm -q up2date
up2date-4.5.5-5.el4

# tail -25 /var/log/up2date
[Wed May 16 11:46:55 2007] up2date availablePackageList from network
[Wed May 16 11:46:57 2007] up2date allAvailablePackageList from network
[Wed May 16 11:47:00 2007] up2date solving dep for: ['jaxp_parser_impl',
'xml-commons-apis']
[Wed May 16 11:47:01 2007] up2date solving dep for:
['xml-commons-jaxp-1.3-apis', 'xml-commons-resolver12', 'xml-commons']
[Wed May 16 11:47:02 2007] up2date solving dep for: ['xml-commons']
[Wed May 16 11:47:03 2007] up2date   File "/usr/sbin/up2date", line 1272, in ?
    sys.exit(main() or 0)
   File "/usr/sbin/up2date", line 791, in main
    fullUpdate, dryRun=options.dry_run))
   File "/usr/sbin/up2date", line 1127, in batchRun
    batch.run()
   File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 82, in run
    self.__dryRun()
   File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 204, in __dryRun
    self.percentCallback)
   File "/usr/share/rhn/up2date_client/up2date.py", line 384, in dryRun
    ret = depsolve.solvedep()
   File "/usr/share/rhn/up2date_client/depSolver.py", line 752, in solvedep
    ret = self.process_deps(deps)
   File "/usr/share/rhn/up2date_client/depSolver.py", line 646, in process_deps
    changed = self.__dependencies(dependencies)
   File "/usr/share/rhn/up2date_client/depSolver.py", line 409, in __dependencies
    if iPkg[4] == aPkg[4] or iPkg[4] == "noarch" or aPkg[4] == "noarch":

Comment 1 RHEL Product and Program Management 2007-05-16 16:24:35 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 2 Pradeep Kilambi 2007-05-16 16:30:22 UTC

*** This bug has been marked as a duplicate of 235140 ***

Comment 3 Brandon Perkins 2007-05-24 17:26:22 UTC
DUPLICATE of bug 235140


Note You need to log in before you can comment on or make changes to this bug.