Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 240112 - [REGRESSION] 0.4.8 does not visit subdirs anymore
Summary: [REGRESSION] 0.4.8 does not visit subdirs anymore
Keywords:
Status: CLOSED DUPLICATE of bug 228827
Alias: None
Product: Fedora
Classification: Fedora
Component: createrepo
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-15 09:50 UTC by Enrico Scholz
Modified: 2014-01-21 22:58 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-07-29 13:21:43 UTC


Attachments (Terms of Use)
fixes directory traversing regression introduced after createrepo 0.4.4 (deleted)
2007-07-07 12:08 UTC, Enrico Scholz
no flags Details | Diff

Description Enrico Scholz 2007-05-15 09:50:09 UTC
Description of problem:

Having a directory layout like

.
|-- RPMS.epel -> ../../5-epel/i386
|-- RPMS.local -> ../../5-local/i386
|-- RPMS.os -> ../../5/i386
|-- RPMS.updates -> ../../5-updates/i386
|-- comps.xml
|-- images -> ../i386/base
`-- repodata


With createrepo-0.4 I could create repodata for all files within the
subdirs. createrepo-0.4.8 refuses this and creates empty repodata.



With createrepo-0.4.8-2

| # createrepo `pwd`
| 
| Saving Primary metadata
| Saving file lists metadata
| Saving other metadata

(and repodata does not provide information about a single package)


With createrepo-0.4.4-2 (from FC6) I get

| # createrepo `pwd`
| 2363/2363 - RPMS.updates/libstdc++-devel-4.1.1-52.el5.2.i386.rpm
| Saving Primary metadata
| Saving file lists metadata
| Saving other metadata


Version-Release number of selected component (if applicable):

createrepo-0.4.8-2


How reproducible:

100%

Comment 1 Paul Nasrat 2007-05-17 13:31:18 UTC
Is this still the case with 0.4.9?

Comment 2 Enrico Scholz 2007-06-08 07:04:59 UTC
it is still the case with createrepo-0.4.10-1.fc8

Comment 3 Enrico Scholz 2007-07-07 12:08:14 UTC
Created attachment 158715 [details]
fixes directory traversing regression introduced after createrepo 0.4.4

attached patch should fix this and adds a testsuite which checks a layout like

repo
|-- B -> ../link0/
|   |-- A -> ../link2/
|   |	|-- dummy-08-0-0.noarch.rpm
|   |	`-- dummy-09-0-0.noarch.rpm -> ../rpms/dummy-09-0-0.noarch.rpm
|   |-- a/
|   |-- dummy-06-0-0.noarch.rpm
|   `-- dummy-07-0-0.noarch.rpm -> ../rpms/dummy-07-0-0.noarch.rpm
|-- a/
|   |-- A -> ../../link1/
|   |-- b/
|   |	|-- dummy-04-0-0.noarch.rpm
|   |	`-- dummy-05-0-0.noarch.rpm -> ../../../rpms/dummy-05-0-0.noarch.rpm
|   |-- dummy-02-0-0.noarch.rpm
|   `-- dummy-03-0-0.noarch.rpm -> ../../rpms/dummy-03-0-0.noarch.rpm
|-- c/
|-- dummy-00-0-0.noarch.rpm
`-- dummy-01-0-0.noarch.rpm -> ../rpms/dummy-01-0-0.noarch.rpm



Current 'createrepo' fails with an exception there.

Comment 4 Seth Vidal 2007-07-29 13:21:43 UTC

*** This bug has been marked as a duplicate of 228827 ***


Note You need to log in before you can comment on or make changes to this bug.