Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 240 - Problems with swedish characters (edv)
Summary: Problems with swedish characters (edv)
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kbd
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
: 259 905 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-11-30 19:43 UTC by Johan Sultan
Modified: 2008-05-01 15:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-04-08 22:26:49 UTC


Attachments (Terms of Use)

Description Johan Sultan 1998-11-30 19:43:55 UTC
Hello!

I just installed redhat 5.2 and noticed that some swedish
characters (edv) were displayed as greek characters.
I would suspect the problem is with the kbd package. I
managed to hack around it by using using the command
setfont /usr/lib/kdb/consolefonts/iso01.f16.gz
last in my rc.local. The problem was solved by that, so it
seems like the problem was just with the displaying of the
characters.

	/Johan Sultan

Comment 1 Johan Sultan 1998-12-10 06:54:59 UTC
I also discovered that the se-latin-1 keytable is screwed up.
It missed some important keys like ] and }. I managed to fix that
by changing to the fi-latin-1 keytable.
	/Johan Sultan

Comment 2 David Lawrence 1999-01-21 17:59:59 UTC
*** Bug 259 has been marked as a duplicate of this bug. ***

On swedish layout not signs ( ] }). Added missing text in map file. Haven't looked for more errors.

------- Additional Comments From dkl@redhat.com  12/02/98 13:12 -------
Could you please be more descriptive on where this problem is occuring
and what exactly you did to get rid of it. Thanks.

------- Additional Comments From jacs@rocketmail.com  12/03/98 05:34 -------
When you want to use this signs on the console or the vi-editor.
Decompressed the se-latin1.map.gz file and used the vi-editor to edit the file. Looked on those keys that should hold the text for those signs, my other signs ({ [) worked. More complete information can I send to you when I come home from work because we don't have Linux at work.

------- Additional Comments From jacs@rocketmail.com  12/03/98 13:57 -------
This is how my se-latin1.map.gz looks like.
keycode  10 = nine             parenright       (bracketright)
	alt     keycode  10 = Meta_nine
keycode  11 = zero             equal            (braceright)
	alt     keycode  11 = Meta_zero

Text in parent is added to this file and it helpt me with my problem.*** Bug 905 has been marked as a duplicate of this bug. ***

When using keyboard layout SE-LATIN1 there are several
bugs in console mode. It works in X windows. The problem is
that Swedish chars "edv" looks like chars from greece and
"]" doesn't work at all. That's the bugs i found so far in
SE-LATIN1.
THanks
Stefan Wold

------- Additional Comments From stefan.wold@sbab.se  01/21/99 03:42 -------
And this have been tested of several of my friends in sweden, they
all have the same problem.
--Stefan

Comment 3 Jeff Johnson 1999-03-30 16:28:59 UTC
Red Hat 6.0 uses console-tools rather than kbd (although many of
the fonts are identical). Does this problem persist with the
Red Hat 6.0 beta console-tools package (see ftp.redhat.com/starbuck
and compile from src rpm if you want to test on Red Hat 5.2)

Comment 4 Jeff Johnson 1999-04-08 22:26:59 UTC
Please reopen this bug if console-tools still has the reported
problem.


Note You need to log in before you can comment on or make changes to this bug.