Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 239605 - anaconda screen garbled unless passed resolution=1680x1050
Summary: anaconda screen garbled unless passed resolution=1680x1050
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Target F8Blocker
TreeView+ depends on / blocked
 
Reported: 2007-05-09 20:41 UTC by David Nielsen
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version: xorg-x11-drv-ati-6.7.192-1.fc8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-09-16 16:03:05 UTC


Attachments (Terms of Use)
anaconda.xlog (deleted)
2007-05-09 20:41 UTC, David Nielsen
no flags Details
Correct X.log (deleted)
2007-05-09 20:59 UTC, David Nielsen
no flags Details

Description David Nielsen 2007-05-09 20:41:46 UTC
Description of problem:
This one has been around since FC6 at least and it presists in the FC7test4 DVD,
the anaconda screen is garbled beyond use unless I pass resolution=1680x1050,
after the install the setup is detected correctly.

using the r200 driver on a LG L204WT-BF monitor.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. boot FC7test4 DVD
  
Actual results:
2. notice garbled screen

Expected results:
correctly detected display

Additional info:

Comment 1 David Nielsen 2007-05-09 20:41:46 UTC
Created attachment 154427 [details]
anaconda.xlog

Comment 2 David Nielsen 2007-05-09 20:59:58 UTC
Created attachment 154429 [details]
Correct X.log

And let's try that again while I'm not being stupid, attached X.log file from a
system where I didn't pass that parameter in question.. doh.

Comment 3 Adam Jackson 2007-05-09 21:29:23 UTC
Almost certainly a radeon bug.

Comment 4 Will Woods 2007-05-22 13:53:18 UTC
This isn't a regression from FC6, and we have a workaround, so I'm moving this
off the blocker list. We may need a release note / CommonBugs entry about this
for F7, though.

Comment 5 David Nielsen 2007-06-26 12:57:35 UTC
Since this has persisted since FC6 I'm setting this to block F8

Comment 6 Adam Jackson 2007-08-27 18:00:09 UTC
Would be good to get a test of this with f8t2 or so.  There's a new radeon
driver that has a good chance of either making this work, or breaking it completely.

Comment 7 David Nielsen 2007-09-16 16:03:05 UTC
I tested with F8 test 2 and is anaconda no longer garbled, closing.


Note You need to log in before you can comment on or make changes to this bug.