Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 238849 - USB sticks are not shown on desktop
Summary: USB sticks are not shown on desktop
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: udev
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
: 238327 (view as bug list)
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2007-05-03 12:58 UTC by Sebastian Vahl
Modified: 2007-11-30 22:12 UTC (History)
4 users (show)

Fixed In Version: udev-106-4.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-09 09:41:12 UTC


Attachments (Terms of Use)

Description Sebastian Vahl 2007-05-03 12:58:50 UTC
Description of problem: 
If you plug in an usb stick the popup window will appear where you can mount the
usb stick. But on the desktop no icon is shown.
With original test4 and logged in through gdm it was working (kdebase-3.5.6-5.fc7)


Version-Release number of selected component (if applicable): kdebase-3.5.6-6.fc7


How reproducible:


Steps to Reproduce:.
1. Do a fresh install from test4 and login through gdm
2. plug in an usb stick and see the icon on desktop
3. yum update && reboot (for new kernel)
4. login through gdm or kdm and plug in an usb stick
  
Actual results: no icon for usb stick on desktop


Expected results: there should be an icon


Additional info: Doesn't matter if the usb stick is mounted or not. The icon
would not be shown. CDs/DVDs are working.

Comment 1 Kevin Kofler 2007-05-08 21:11:23 UTC
Looks like this is _not_ related to #228111 (KDM/ConsoleKit), but that's pretty 
much as far as we got.

Comment 2 Sebastian Vahl 2007-05-09 09:19:15 UTC
It seems the problem only occurs with the latest udev. My test installation for
this is an up-to-date rawhide with udev-106-3.fc7.i386. With this one I don't
have a desktop icon for my usb stick. And even kpopup don't show digikam for
importing images.
If I downgrade to udev-106-2.fc7.i386 I have a desktop icon and also kpopup
shows digikam.

I don't know how to provide further informations. Please let me know what you
need for debugging this.

Comment 3 Sebastian Vahl 2007-05-09 09:35:44 UTC
With udev-106-4.fc7 (which isn't released yet) it seems to work again:
http://koji.fedoraproject.org/koji/packageinfo?packageID=36

See also: #238140



Comment 4 Kevin Kofler 2007-05-09 09:41:12 UTC
udev-106-4.fc7 is already tagged f7-final, so it will enter Rawhide as soon as 
it reopens.

Comment 5 Kevin Kofler 2007-05-10 15:55:25 UTC
*** Bug 238327 has been marked as a duplicate of this bug. ***

Comment 6 Stefan Becker 2007-05-11 16:09:57 UTC
Confirmed. Problem gone with udev-106-4.fc7 RPM from koji.


Note You need to log in before you can comment on or make changes to this bug.