Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 238497 - Evo crashes while sorting message list by "to" column
Summary: Evo crashes while sorting message list by "to" column
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
: 220371 233613 234675 (view as bug list)
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2007-04-30 21:18 UTC by Peter Jones
Modified: 2007-11-30 22:12 UTC (History)
3 users (show)

Fixed In Version: evolution-2.10.1-10.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-01 15:58:50 UTC


Attachments (Terms of Use)
Patch that fixes the crash (correctly, I think) (deleted)
2007-04-30 21:18 UTC, Peter Jones
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 373713 None None None Never

Description Peter Jones 2007-04-30 21:18:36 UTC
Description of problem:  I clicked the "To" column header to sort by recipients
in my Sent mail folder, and evo crashed.


Version-Release number of selected component (if applicable): 2.10.1-4.1 (but it
appears this crash was present in 2.9 as well).


How reproducible: Not sure; it only happens when it treats the field as
"normalized", but I don't know when that is.

Patch attached.

Comment 1 Peter Jones 2007-04-30 21:18:36 UTC
Created attachment 153827 [details]
Patch that fixes the crash (correctly, I think)

Comment 2 Matthew Barnes 2007-05-01 15:58:50 UTC
Confirmed that the patch fixes the crash.  Thanks Peter!

This turned out to be a bug in a patch I submitted for [1].
It's only in Rawhide, not upstream.

Fixed in evolution-2.10.1-10.fc7.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=363695

Comment 3 Matthew Barnes 2007-05-01 16:08:51 UTC
*** Bug 233613 has been marked as a duplicate of this bug. ***

Comment 4 Matthew Barnes 2007-05-01 16:12:44 UTC
*** Bug 234675 has been marked as a duplicate of this bug. ***

Comment 5 Matthew Barnes 2007-05-01 16:28:00 UTC
*** Bug 220371 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.