Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 238371 - kde-settings: lacking xdg-user-dirs integration
Summary: kde-settings: lacking xdg-user-dirs integration
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kde-settings
Version: rawhide
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: FC7Target 240556
TreeView+ depends on / blocked
 
Reported: 2007-04-29 22:27 UTC by Jason Frothingham
Modified: 2013-01-10 04:17 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-16 16:23:09 UTC


Attachments (Terms of Use)

Description Jason Frothingham 2007-04-29 22:27:00 UTC
Description of problem: Install to Hard Drive missing from KDE version of Fedora
7 Test #4


Version-Release number of selected component (if applicable): Fedora 7 Test #4
Live CD- KDE


How reproducible: Every single .iso version I've downloaded through the mirrors.


Steps to Reproduce: 
1. Download .iso for Test #4 Live CD
2. Burn .iso
3. Leave in drive and reboot
4. try to figure out where the installer is on reboot.
5: Realize the install to hard drive is missing and anaconda won't run.
  
Actual results: No installation of KDE Live CD.


Expected results: Was hoping to install from KDE Live CD. Can't stand gnome.


Additional info: I apologize if this bug report comes off as a bit... jerkish.
I'm just trying to figure out how the install feature could have been left out
of the KDE version.

Comment 1 Jeremy Katz 2007-04-30 18:31:21 UTC
This comes up fine here -- are you logging in as the fedora user for the live CD?

Comment 2 Luc 2007-04-30 19:36:24 UTC
Have the same problem if I choose a language in the login screen: No shortcut to
the install program.
OK if I log directly without choosing any language: In that case I find the
Install shortcut onto my desktop

Comment 3 Sebastian Vahl 2007-05-01 10:20:49 UTC
The file /home/fedora/Desktop/liveinst.desktop should be placed there during the
login. If you login as root it would be hidden (KDE seems to don't like
"NoDisplay=true" in liveinst.desktop. This is replaced by "NoDisplay=false" for
User "fedora"). 
/home/fedora/Desktop/liveinst.desktop should be definetily there. You should at
least see it in a terminal with "ls /home/fedora/Desktop"

Comment 4 Luc 2007-05-01 14:55:39 UTC
I made a new test.
I choosed the French language in the login screen. Then I put that language as 
default  in the popup window asking if the language is just for that session 
or by default.
After  login I confirm that the Icon is not displayed on the desktop.
The file liveinst.desktop exists but is in the folder /home/fedora/Bureau/ 
(and not /home/fedora/Desktop/)
You will notice that 'Bureau' is the French translation of 'Desktop'.
Surprisingly, If I move the file liveinst.desktop in the right folder 
(/home/fedora/Desktop/), I still don't see the icon on the desktop.

Comment 5 Rex Dieter 2007-05-01 15:02:47 UTC
Ah, only English works atm, we need to integrate xdg-user-dirs.

This is a kde-specific issue then (not really livecd)... I'll re-assign this in
a bit, when I figure out where best to put it. 

Comment 6 Sebastian Vahl 2007-05-09 21:06:42 UTC
For the final we will use kdm with autologin. So this problem would not occur.
Also I replaced "NoDisplay=true" with "NoDisplay=False" in
/usr/share/applications/liveinst.desktop directly. So if someone boot with
"live_locale=<locale>" there would be at least a icon in the menu.

Comment 7 Rahul Sundaram 2007-05-13 18:35:24 UTC
Sebastian, has all the changes required to fix this problem already been
committed and tested? What's the status?

Comment 8 Sebastian Vahl 2007-05-14 11:24:48 UTC
(In reply to comment #7)
> Sebastian, has all the changes required to fix this problem already been
> committed and tested? What's the status?

I've committed the changes described in comment #6 before I wrote that comment.

But the main problem here is that the integration of xdg-user-dirs needs some
love (see comment #5). So maybe I should re-assign this to Rex and/or Than?



Comment 9 Sebastian Vahl 2007-05-14 11:27:27 UTC
Oh. Just to make this clear: My changes are for livecd-fedora-kde.ks (for the
livecd), not for kdebase or xdg-user-dirs.

Comment 10 Rex Dieter 2007-05-14 11:57:26 UTC
Reassigning to kde-settings, removing FC7Blocker (since we don't non-English 
atm anyway)

Comment 11 Rex Dieter 2007-05-16 16:23:09 UTC
* Tue May 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.5-24
...
- kdeglobals: xdg-user-dirs integration: Desktop, Documents (#238371)

Basic/initial integration, inserting into kdeglobals:
[Paths]
Desktop[$e]=$(xdg-user-dir DESKTOP)
Documents[$e]=$(xdg-user-dir DOCUMENTS)

So that the output of the following now match:
kde-config --userpath desktop  =  xdg-user-dir DESKTOP
kde-config --userpath document =  xdg-user-dir DOCUMENTS

Now, we can do likewise for multimedia app configs wrt to XDG_MUSIC_DIR,
XDG_PICTURES_DIR, XDG_VIDEOS_DIR

Comment 12 Rex Dieter 2007-05-18 13:00:45 UTC
Followup additions:

* Fri May 18 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.5-27
...
- kdeglobals: [Paths] Trash[$e]=$(xdg-user-dir DESKTOP)/Trash/
- Requires: xdg-user-dirs



Note You need to log in before you can comment on or make changes to this bug.