Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 238155 - Evolution crashes when starting
Summary: Evolution crashes when starting
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2007-04-27 15:13 UTC by Espen Stefansen
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: evolution-2.10.1-14.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-14 20:50:28 UTC


Attachments (Terms of Use)
evolution crash-log with debuginfo (deleted)
2007-04-27 16:48 UTC, Espen Stefansen
no flags Details
Crash-log (deleted)
2007-05-14 14:00 UTC, Espen Stefansen
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 427232 None None None Never

Description Espen Stefansen 2007-04-27 15:13:52 UTC
Description of problem:
Evolution crashes when it's started from the menu. It complains about the task-
application.

Version-Release number of selected component (if applicable):
evolution-2.10.1-4.fc7
evolution-data-server-1.10.1-1.fc7

How reproducible:
Every time Evolution is started

Steps to Reproduce:
1. Start Evolution
2.
3.
  
Actual results:
Crash

Expected results:
A working Evolution

Additional info:
Link to the bug in Gnome bugzilla: http://bugzilla.gnome.org/
show_bug.cgi?id=427232

Comment 1 Matthew Barnes 2007-04-27 16:28:07 UTC
Thanks for reporting this.

Can you please attach the Bug Buddy output to this bug the next time you
encounter the crash?  The debugging information in the GNOME bug does not look
valid.

Comment 2 Espen Stefansen 2007-04-27 16:48:14 UTC
Created attachment 153642 [details]
evolution crash-log with debuginfo

evolution crash-log with debuginfo

Comment 3 Espen Stefansen 2007-05-04 08:58:10 UTC
This error happens on 2 of my computers. But if I start Evolution as root, it 
works.

Comment 4 Matthew Barnes 2007-05-07 17:24:43 UTC
Can I have you post the value of one of your GConf keys please?

I'm looking for GConf key /apps/evolution/calendar/sources.  This key will
consist of a list of strings, with each string containing XML data.  There
should be an entry in that list that has the words "On This Computer" toward the
beginning.  Please copy and paste that entry here.

For example, here's what mine looks like:

<?xml version="1.0"?>
<group uid="1170178558.3187.11@baloo.boston.redhat.com" name="On This Computer"
base_uri="file:///home/mbarnes/.evolution/calendar/local" readonly="no"><source
uid="1170178558.3187.12@baloo.boston.redhat.com" name="Personal"
relative_uri="system" color="becedd"><properties><property name="alarm"
value="true"/></properties></source></group>

I'm looking for whether you have a <source> tag that's missing a "relative_uri"
attribute.  My example above has one.  If I remove that attribute and start
Evolution, Evolution immediately crashes with exactly the same backtrace as you
posted.

If you can confirm that your GConf is missing a "relative_uri" attribute, I
should be able to get this crash fixed straight away.

Comment 5 Espen Stefansen 2007-05-08 20:31:37 UTC
I'm actually missing "sources". In .gconf/apps/evolution/calendar/ there should
be a sources file right?

In gconf-editor, it says; this key has no schema. But it shows this:
<?xml version="1.0"?>
<group uid="1175376361.5631.1@rawhide-vm" name="On This Computer"
base_uri="file:///home/espens/.evolution/calendar/local" readonly="no"><source
uid="1175376361.5631.0@rawhide-vm" name="Personal"
uri="file:///home/espens/.evolution/calendar/local/system"
color_spec="#becedd"/></group>
<?xml version="1.0"?>
<group uid="1176421615.4239.0@rawhide-vm" name="CalDAV" base_uri="caldav://"
readonly="no"/>


Comment 6 Matthew Barnes 2007-05-09 01:19:17 UTC
It's easier to install the gconf-editor package and look at the configuration
data that way (via Applications -> System Tools -> Configuration Editor), but
yeah that's the data I was looking for.  I see you have an absolute uri tag but
not a relative uri tag, which is fine.  Evolution is handling it wrong.

Try updating to evolution-2.10.1-13.fc7 and see if that works better for you.

Comment 7 Espen Stefansen 2007-05-14 14:00:32 UTC
Created attachment 154645 [details]
Crash-log

It took my some time to find where i could try the new evolution packages. :)
Unfortunately, evolution still crashes. I attached the new crash-log.

Comment 8 Matthew Barnes 2007-05-14 14:47:59 UTC
Same logic error but different location, looks like.

Comment 9 Matthew Barnes 2007-05-14 17:04:50 UTC
Actually this same logic error showed up in quite a number of places throughout
Evolution.  I've attempted to fix as many as I could find, including the
location where you reported the latest crash.

Please try upgrading to evolution-2.10.1-14.fc7 or later.

Comment 10 Espen Stefansen 2007-05-14 20:34:38 UTC
Good news! I upgraded to evolution-2.10.1-14.fc7 and now evolution starts up as 
it should. :)

Comment 11 Matthew Barnes 2007-05-14 20:50:28 UTC
Awesome!  I'll close this bug then, but feel free to reopen it if you still have
trouble starting Evolution.


Note You need to log in before you can comment on or make changes to this bug.