Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2373 - problem with language and documetation (rpm, v. 2.9x-3.0)
Summary: problem with language and documetation (rpm, v. 2.9x-3.0)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-04-26 18:25 UTC by pius
Modified: 2015-01-07 23:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-01 15:14:51 UTC


Attachments (Terms of Use)

Description pius 1999-04-26 18:25:29 UTC
There is a problem with building/installing rpm packages which contains
%lang macros in the spec file. The problem is that files in %doc are getting
the same language as that set in the last line of %files. So if there are
some files labeled with %lang macro at the end of the %files section and
the last one is %lang(xx), documentation files will get default language set
to xx (no matter what lang it will be). And if there's no xx language
in LINGUAS or LANG variable, documentation files won't be installed.
This problem is common for all of the 2.9x rpm versions to current (3.0.1).

Comment 1 Jeff Johnson 1999-05-01 15:12:59 UTC
Fixed in rpm-3.0.1-4 (and cvs). Thanks for finding.

Comment 2 Jeff Johnson 1999-05-01 15:14:59 UTC
Actually the inheritance of last %lang to %doc is what was
fixed. Files that are marked with %lang are not installed unless
mentioned in LANG or LINGUAS at install time.


Note You need to log in before you can comment on or make changes to this bug.