Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 237186 - LSPP: writes to /selinux/avc/cache_threshold can enexpectedly succeed
Summary: LSPP: writes to /selinux/avc/cache_threshold can enexpectedly succeed
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Red Hat Kernel Manager
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks: RHEL5LSPPCertTracker
TreeView+ depends on / blocked
 
Reported: 2007-04-19 21:27 UTC by Trevor Highland
Modified: 2007-11-30 22:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-20 20:06:06 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Trevor Highland 2007-04-19 21:27:31 UTC
Description of problem:
Writes to /selinux/avc/cache_threshold succeed by users without write
permission, if the user tries to write the value currently in the file.

Version-Release number of selected component (if applicable):
  2.6.18-8.1.1.lspp.76.el5

How reproducible:
  This behavior can always be reproduced.


Steps to Reproduce:
1.
  Login with the staff_r role and become root.
2.
   cat /selinux/avc/cache_threshold
3.
   echo [current contents] > /selinux/avc/cache_threshold
   write succeeds.
4. echo [different value] > /selinux/avc/cache_threshold
   write error: permission denied

Actual results:
  Under a role without write access to a /selinux/avc/cache_threshold.  The
  user is able to write the value currently in the file without having the write 
  fail with a permission denied error.

Expected results:
  Any call to the write system call made by a user without write permission 
  should return EPERM.  It is misleading for writes to succeed because the value 
  in the file is unchanged.

Additional info:

Comment 1 Steve Grubb 2007-04-20 20:06:06 UTC
I think this was discussed on the LSPP mail list and the group consensus was
that since this is a interface accessible only by an admin, its OK. Closing this
request.


Note You need to log in before you can comment on or make changes to this bug.