Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236836 - [RHEL5 RT][OPENIB]rdma capability not working with RT kernel.
Summary: [RHEL5 RT][OPENIB]rdma capability not working with RT kernel.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-kernel
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Doug Ledford
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-17 21:02 UTC by Gurhan Ozen
Modified: 2008-02-27 19:58 UTC (History)
2 users (show)

Fixed In Version: -35
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-02 14:52:56 UTC


Attachments (Terms of Use)

Description Gurhan Ozen 2007-04-17 21:02:24 UTC
Description of problem:
  rdma userspace programs can't be run on RT kernel due to kernel abi mismatch:

# ucmatose
librdmacm: kernel ABI version 4 doesn't match library version 2.
failed to create event channel


Version-Release number of selected component (if applicable):
# rpm -qa | grep rdma
librdmacm-utils-0.9.1-5.el5
librdmacm-0.9.1-5.el5
librdmacm-devel-0.9.1-5.el5
# uname -a
Linux dell-pe1950-02.rhts.boston.redhat.com 2.6.20-19.el5rt #1 SMP PREEMPT Mon
Apr 16 12:14:21 EDT 2007 x86_64 x86_64 x86_64 GNU/Linux


How reproducible:
Very

Steps to Reproduce:
1. Boot into RT kernel with a system that has infiniband hardware and try to run
ucmatose 
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Doug Ledford 2007-07-10 20:53:03 UTC
This is resolved by using the openib-1.2-1.el5 packages.

Comment 2 Doug Ledford 2007-07-10 21:31:33 UTC
openib-1.2-1.el5 has been tagged into dist-5E-rt which means they'll get picked
up in the next rhel-rt compose.

Comment 3 Gurhan Ozen 2007-08-13 21:00:40 UTC
Verified with -35:
[root@dell-pe1950-02 ~]# ucmatose -b 192.168.1.10 
cmatose: starting server
initiating data transfers
completing sends
receiving data transfers
data transfers complete
cmatose: disconnecting
disconnected
test complete
return status 0
[root@dell-pe1950-02 ~]# uname -a
Linux dell-pe1950-02.rhts.boston.redhat.com 2.6.21-35.el5rt #1 SMP PREEMPT RT
Thu Jul 26 11:59:02 EDT 2007 x86_64 x86_64 x86_64 GNU/Linux


Note You need to log in before you can comment on or make changes to this bug.