Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236830 - C-a C-x in reply window doesn't clear original message
Summary: C-a C-x in reply window doesn't clear original message
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 7
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-17 20:38 UTC by Jonathan Kamens
Modified: 2008-02-11 18:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-02-11 18:44:01 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 515840 None None None Never

Description Jonathan Kamens 2007-04-17 20:38:57 UTC
evolution-2.10.1-4.fc7

Highlight a message.  Click reply.  In the reply window, type C-a C-x, which
should clear the old message from the window.  Instead, it leaves you with a
blank line followed by an angle bracket (or, if you're using HTML format, a
quoting pipe).

If you add a linefeed to the last line of the quoted message, which doesn't have
one when the reply window pops up, and then hit C-a C-x, the window is cleared
as expected.

I don't know whether it's the C-a or C-x that's doing the wrong thing.

Comment 1 Milan Crha 2007-11-21 10:16:19 UTC
It seems to me like fixed, in Fedora 8, can you check, please? (I meant, I
cannot reproduce this in Fedora 8, it works as expected for me.)

Comment 2 Jonathan Kamens 2007-11-22 18:36:35 UTC
Weird.  It's "sort of" fixed.  If you start a reply with the quoting method set 
to quote rather than Outlook-style, then hit C-a C-x, the entire quoted message 
gets removed.  Now here's where it gets weird.  If you how hit ctrl-z, and then 
hit ctrl-a ctrl-x again, once again you end up with an angle bracket or quoting 
bar left over.  Not entirely fixed.


Comment 3 Milan Crha 2008-02-11 18:44:01 UTC
Moving this upstream, see bug [1] for more information.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=515840


Note You need to log in before you can comment on or make changes to this bug.