Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236827 - ricci uninstallable on ppc
Summary: ricci uninstallable on ppc
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: conga
Version: 4
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ryan McCabe
QA Contact: Corey Marthaler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-17 20:33 UTC by Nate Straz
Modified: 2009-04-16 20:27 UTC (History)
5 users (show)

Fixed In Version: 4.5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-09 22:30:12 UTC


Attachments (Terms of Use)

Description Nate Straz 2007-04-17 20:33:35 UTC
Description of problem:

I was trying to install everything in the cluster tarball from cfeist and I hit
the following error:

Unresolvable chain of dependencies:
ricci  0.9.1-6                           requires libmagic.so.1()(64bit)

It appears that ricci is 64 bit but libmagic (from the file rpm) is not.

I think this means that customers will not be able to use Conga to configure
ppc nodes.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. install base RHEL on ppc64
2. up2date --installall=cluster
  
Actual results:
See Above

Expected results:
ricci should install.

Additional info:

Comment 3 Kiersten (Kerri) Anderson 2007-04-24 15:19:52 UTC
Need this in 4.5 release.  QE has machines to use for figuring the problem out.
 Nate will provide machine name.

Comment 5 Ryan McCabe 2007-04-24 20:58:56 UTC
I think this is a bug in the dependency resolver (or something in that area):

[root@kent ~]# up2date --whatprovides="libmagic.so.1"
file-4.10-3.EL4.5.ppc

[root@kent ~]# up2date --whatprovides="libmagic.so.1()(64bit)"
[root@kent ~]# 

Other 64-bit libraries that ricci needs are accounted for correctly e.g.,

[root@kent ~]# up2date --whatprovides="libcrypto.so.4()(64bit)"
openssl-0.9.7a-43.16.ppc64

If I manually install the ppc64 "file" package (file-4.10-3.EL4.5.ppc64.rpm),
I'm able to run up2date successfully, and I get this output from rpm:

[root@newport SPECS]# rpm -q --provides file-4.10-3.EL4.5.ppc64
libmagic.so.1()(64bit)  
file = 4.10-3.EL4.5

Is there someone around who's more familiar with the build system who might know
how to go about getting this fixed?

Comment 6 Ryan McCabe 2007-04-30 18:42:57 UTC
Closing as NOTABUG--we're going to build 32-bit. 64-bit packages aren't supported.

Comment 7 Nate Straz 2007-04-30 19:54:25 UTC
It's still a bug that we don't have ppc packages that install.  We need to be
able track that this problem is fixed.  I don't see how this could possibly be
NOTABUG.

Comment 8 Ryan McCabe 2007-05-02 01:16:18 UTC
In the 0.9.1-8 build, the ppc64 arch is excluded. This should adequately work
around the problem, provided that the right bits make it to RHN.


Note You need to log in before you can comment on or make changes to this bug.