Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236804 - Mail from logwatch bounces
Summary: Mail from logwatch bounces
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: sendmail
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-17 18:50 UTC by Pete Zaitcev
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-01 19:36:04 UTC


Attachments (Terms of Use)

Description Pete Zaitcev 2007-04-17 18:50:58 UTC
Description of problem:

Mail bounces becasue localdomain is a bad domain:

   ----- The following addresses had permanent fatal errors -----
root
    (reason: 553 5.5.4 <root@localhost.localdomain>... Real domain name required
for sender address)
    (expanded from: root)

   ----- Transcript of session follows -----
... while talking to [127.0.0.1]:
>>> MAIL From:<root@localhost.localdomain> SIZE=20837
AUTH=root@localhost.localdomain
<<< 553 5.5.4 <root@localhost.localdomain>... Real domain name required for
sender address
501 5.6.0 Data format error

Version-Release number of selected component (if applicable):

sendmail-8.14.1-1.1

How reproducible:

100% for the given configuration

Steps to Reproduce:
1. Update sendmail
  
Actual results:

Mail from cron tasks breaks.

Expected results:

Mail delivered to sysadmin.

Additional info:

The error is trivial to fix by editing /etc/sendmail.cf, but the point
is, this should not happen in configs where everything is 100% stock.

Comment 1 Thomas Woerner 2007-04-25 11:27:17 UTC
Could it be that there is no localhost.localdomain entry in /etc/hosts?

Comment 2 Pete Zaitcev 2007-04-25 16:53:07 UTC
1. It's there:

[zaitcev@niphredil ~]$ grep localhost /etc/hosts
127.0.0.1       localhost.localdomain localhost niphredil.zaitcev.lan
::1             localhost6.localdomain6 localhost6
[zaitcev@niphredil ~]$ 

2. This is a regression. Worked before update, stopped after update,
without changes to the /etc/hosts.

Comment 3 Thomas Woerner 2007-08-01 14:09:37 UTC
I can not reproduce the problem here at all. It is working as expected.
Can you please verify if this is still happening for you with the original
configuration?

Comment 4 Pete Zaitcev 2007-08-01 19:36:04 UTC
Looks like it's not happening anymore, although on the other hand I stopped
getting mails from logwatch altogether some time ago.


Note You need to log in before you can comment on or make changes to this bug.