Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236803 - kdebase: Some UTF-8 chars not showing up in konsole
Summary: kdebase: Some UTF-8 chars not showing up in konsole
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: qt
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks: F9Target
TreeView+ depends on / blocked
 
Reported: 2007-04-17 18:48 UTC by Christopher Stone
Modified: 2008-03-28 12:20 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-03-28 12:20:34 UTC


Attachments (Terms of Use)
konsole screenshot (deleted)
2007-07-02 14:38 UTC, Ngo Than
no flags Details
Example Characters that do not show up in Konsole (deleted)
2007-10-04 21:47 UTC, Christopher Stone
no flags Details
rawhide 20080308 (deleted)
2008-03-06 03:17 UTC, Caius Chance
no flags Details

Description Christopher Stone 2007-04-17 18:48:43 UTC
Description of problem:
I bet it doesn’t do UTF-8

The above text does not show up properly in konsole with limited default fonts
installed.

Seems installing VLGothic-fonts fixes the issue with konsole, however both xterm
and gnome-terminal display the above text properly without VLGothic-fonts installed.

Comment 1 Christopher Stone 2007-04-29 04:19:34 UTC
for some reason ™ does not show up in konsole, but shows up fine with
gnome-terminal and xterm.

Comment 2 Christopher Stone 2007-05-01 06:11:54 UTC
The characters 〈 and 〉 do not show up in konsole either.

Comment 3 Gianluca Varisco 2007-06-12 10:18:47 UTC
I can confirm that I have the same problem with konsole on F7
(kdebase-3.5.6-12.fc7) but I think that this issue isn't related to
VLGothic-fonts (20070328-1.fc7 installed here), because, anyway, I have the same
problem.

Comment 4 Rex Dieter 2007-06-19 20:52:11 UTC
Than, any ideas here?  I'm at a complete loss.

Comment 5 Ngo Than 2007-07-02 13:18:49 UTC
could you please attach the text file or tell me how i cann reproduce this 
problem? Thanks

Comment 6 Christopher Stone 2007-07-02 13:54:16 UTC
All you have to do in order to reproduce it is simply copy & paste the text in
comments above into a konsole....

Comment 7 Ngo Than 2007-07-02 14:34:08 UTC
i cannot reproduce this problem on my test machine. It works fine for me. 
Here's the screenshot. It seems either font setting problem or missing fonts.
There's a list of font packages installed on my test machine:

pm -qa | grep font
xorg-x11-font-utils-7.1-5.fc7
libfontenc-devel-1.0.4-2.fc7
urw-fonts-2.3-6.1.1
xorg-x11-fonts-ISO8859-1-100dpi-7.1-3.fc7
libXfontcache-devel-1.0.4-1.fc7
libXfont-1.2.8-1.fc7
xorg-x11-fonts-Type1-7.1-3.fc7
libXfontcache-1.0.4-1.fc7
chkfontpath-1.10.1-1.1
xorg-x11-fonts-truetype-7.1-3.fc7
xorg-x11-fonts-misc-7.1-3.fc7
tetex-fonts-3.0-39.fc7
fontconfig-devel-2.4.2-3.fc7
libfontenc-1.0.4-2.fc7
ghostscript-fonts-5.50-16.fc7
fontconfig-2.4.2-3.fc7
fonts-japanese-0.20061016-6.fc7
xorg-x11-fonts-75dpi-7.1-3.fc7
xorg-x11-fonts-ISO8859-1-75dpi-7.1-3.fc7
bitmap-fonts-0.3-5.1.2.fc7
dejavu-lgc-fonts-2.15-1
xorg-x11-fonts-base-7.1-3.fc7
libXfont-devel-1.2.8-1.fc7
xorg-x11-fonts-100dpi-7.1-3.fc7

could you please install missing font packages and try again? Thanks


Comment 8 Ngo Than 2007-07-02 14:38:00 UTC
Created attachment 158331 [details]
konsole screenshot

Comment 9 Christopher Stone 2007-07-02 15:12:33 UTC
Remove fonts-japanese and test again.  You will see that it does not work in
konsole and does work with gnome-terminal and xterm after you remove the
japanese fonts.

Comment 10 Christopher Stone 2007-07-02 15:21:27 UTC
NOTE: The characters mentioned in comments #2 and #3 will not work in konsole
regardless of japanese (or VLGothic) fonts installed.  These characters work
fine in xterm and gnome-terminal.


Comment 11 Christopher Stone 2007-07-02 15:22:24 UTC
Er, that should be comments #1 and #2, (not 2&3).

Comment 12 Ngo Than 2007-07-03 08:49:00 UTC
it's a font rendering issue in qt. reassign to correct component

Comment 13 Christopher Stone 2007-07-03 17:52:03 UTC
획 기 적 인

^^ This text fails for me in firefox, gnome-terminal and konsole.  However
displays fine with xterm.

Comment 14 Jens Petersen 2007-10-04 05:51:08 UTC
Is this still happening?

I just see a bunch of ?'s in the description and comments above.

Could you attach the text that is not displaying as utf-8 file?

Comment 15 Christopher Stone 2007-10-04 21:47:34 UTC
Created attachment 216481 [details]
Example Characters that do not show up in Konsole

This attachment shows some sample characters which display perfectly within
gnome-terminal and xterm, but which do not show up properly using konsole.

Comment 16 Jens Petersen 2008-03-05 02:40:48 UTC
I think more information is needed: like your locale and list of fonts installed.

Comment 17 Jens Petersen 2008-03-05 02:41:15 UTC
Does it still happen for you with kde4/qt4?

Comment 18 Caius Chance 2008-03-06 03:17:07 UTC
Created attachment 296986 [details]
rawhide 20080308

Comment 19 Caius Chance 2008-03-06 03:20:10 UTC
The konsole could display the above text. However, firefox has problem on
displaying the first text. When I highlighted such text, it could be displayed
instead.

kde-filesystem-4-8.fc9.noarch
kde-settings-kdm-4.0-11.fc9.noarch
kde-l10n-Chinese-4.0.2-1.fc9.noarch
kde-i18n-Chinese-Big5-3.5.9-4.fc9.noarch
kde-i18n-Chinese-3.5.9-4.fc9.noarch
kde-settings-4.0-11.fc9.noarch
kde-settings-pulseaudio-4.0-11.fc9.noarch
kde-l10n-Chinese-Traditional-4.0.2-1.fc9.noarch

qt-3.3.8b-5.fc9.i386
qt4-x11-4.3.4-3.fc9.i386
qt4-4.3.4-3.fc9.i386


Comment 20 Ngo Than 2008-03-28 12:20:34 UTC
i cannot reproduce this problem in current rawhide anymore with or without 
fonts-japanese


Note You need to log in before you can comment on or make changes to this bug.