Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236785 - RFE: expose disk image type?
Summary: RFE: expose disk image type?
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Martin Jenner
URL:
Whiteboard:
: 370161 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-17 17:09 UTC by Jeremy Katz
Modified: 2009-03-23 22:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-03-23 22:09:43 UTC


Attachments (Terms of Use)

Description Jeremy Katz 2007-04-17 17:09:33 UTC
Does it make sense to expose somewhat the different types of disk images which
you can create to use with a guest?  While PV guests currently won't work with
anything other than just raw images, that needs fixing anyway...  and FV/qemu
can work nicely with things like qcow/qcow2/vmdk.  And that makes preallocate vs
not just sparse vs preallocated raw image.

Comment 1 Red Hat Bugzilla 2007-07-25 02:08:38 UTC
change QA contact

Comment 2 Cole Robinson 2008-03-12 19:57:59 UTC
Dan has already explicity rejected anything exposing the underlying storage
driver in virt-manager. With the libvirt storage api integration on the horizon
though I don't know if this will change. Dan?

Comment 3 Daniel Berrange 2008-03-13 03:28:54 UTC
When the storage UI in virt-manager is re-written to support the libvirt storage
API, we will expose the full range of disk formats including qcow/vmdk, etc, so
we should keep this open till that's done.

Comment 4 Cole Robinson 2008-03-15 03:42:17 UTC
*** Bug 370161 has been marked as a duplicate of this bug. ***

Comment 5 Jon Stanley 2008-04-23 20:30:48 UTC
Adding FutureFeature keyword to RFE's.

Comment 6 Cole Robinson 2009-03-10 01:43:53 UTC
Current upstream now allows provisioning more complex storage (file formats included) on demand via the libvirt storage file browser. Moving to POST.

Comment 7 Cole Robinson 2009-03-23 22:09:43 UTC
This is in rawhide as of virt-manager-0.7.0-1. Closing as RAWHIDE.


Note You need to log in before you can comment on or make changes to this bug.