Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236770 - bonding driver fails to forward traffic after link down event
Summary: bonding driver fails to forward traffic after link down event
Keywords:
Status: CLOSED DUPLICATE of bug 236769
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Kernel Maintainer List
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-17 16:04 UTC by Jon Stanley
Modified: 2007-11-17 01:14 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-15 19:06:11 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jon Stanley 2007-04-17 16:04:49 UTC
We are using NIC bonding under the following configuration: 
 
eth0 = first port of first Intel Quad port Gigabit Ethernet controller. 
eth4 = first port of second Intel Quad port Gigabit Ethernet controller. 
bond0 = bonded master interface for eth0+eth4. 
 
When eth0/eth4 cables were disconnected and reconnected to same ports on a 
running system, we experienced lost of network connectivity to the bond0 
interface. 
 
Upon cable reconnect, ethtool showed valid link status as well as correct speed 
& duplex settings for the slave interfaces. (1000/FDX). 
 
bond0 would not recognize a valid slave interface after reconnect. 
 
"grep 'Active Slave' /proc/net/bonding/bond0" produced the following result: 
Currently Active Slave: None. 
 
running "ifconfig <if> down" and "ifconfig <if> up" for each slave interface 
eth0 and eth4 failed to affect the result. 
 
"ifconfig bond0" showed the correct IP address assigned to the bond0 interface, 
but IP traffic failed to reach the system over bond0. 

A reboot of the servers restored service.

Comment 1 Jason Baron 2007-06-15 19:06:11 UTC

*** This bug has been marked as a duplicate of 236769 ***


Note You need to log in before you can comment on or make changes to this bug.