Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236756 - Known-good PDF handling problem (Kew Gardens dayplanner)
Summary: Known-good PDF handling problem (Kew Gardens dayplanner)
Keywords:
Status: CLOSED DUPLICATE of bug 236753
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Update
TreeView+ depends on / blocked
 
Reported: 2007-04-17 15:16 UTC by Tim Waugh
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-09 13:02:50 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
CUPS Bugs and Features 2348 None None None Never

Description Tim Waugh 2007-04-17 15:16:09 UTC
Description of problem:
This PDF document:
http://www.rbgkew.org.uk/visitor/dayplanner.pdf

does not print correctly.

Version-Release number of selected component (if applicable):
cups-1.2.10-3.fc6

How reproducible:
100%

Steps to Reproduce:
1. lp dayplanner.pdf
  
Actual results:
Lots of blank space around the bottom and the right edges of the resulting
landscape pages, with cropped left and top edges.

Expected results:
As shown in evince.

Possibly another symptom of bug #236753.

Comment 1 Tim Waugh 2007-04-17 15:19:59 UTC
Works with printing to a file from xpdf.  Diff:

--- dayplanner-cups.ps  2007-04-17 16:18:59.000000000 +0100
+++ dayplanner-xpdf.ps  2007-04-17 16:19:10.000000000 +0100
@@ -1,12 +1,9 @@
 %!PS-Adobe-3.0
-%cupsRotation: 270
-%Producer: xpdf/pdftops 3.01
-%%Creator: QuarkXPress: pictwpstops filter 1.0
-%%Title: 1692 day_planner v2.qxd
+%%Creator: xpdf/pdftops 3.01
 %%LanguageLevel: 2
 %%DocumentSuppliedResources: (atend)
-%%DocumentMedia: plain 595 842 0 () ()
-%%BoundingBox: 0 0 595 842
+%%DocumentMedia: plain 612 792 0 () ()
+%%BoundingBox: 0 0 612 792
 %%Pages: 2
 %%EndComments
 %%BeginDefaults
@@ -1458,14 +1455,15 @@
   /eth/ntilde/ograve/oacute/ocircumflex/otilde/odieresis/divide
   /oslash/ugrave/uacute/ucircumflex/udieresis/yacute/thorn/ydieresis]
 pdfMakeFont
-595 842 false pdfSetup
+612 792 false pdfSetup
 %%EndSetup
 %%Page: 1 1
 %%BeginPageSetup
-%%PageOrientation: Portrait
+%%PageOrientation: Landscape
 pdfStartPage
-90 rotate
-123.5 -718.5 translate
+180 rotate
+-585.834 -792 translate
+0.9406 0.9406 scale
 0 0 595 842 re W
 %%EndPageSetup
 [] 0 d
@@ -1480,6 +1478,8 @@
 [0] SC
 false op
 false OP
+0 0 595 842 re
+W
 q
 q
 1 i
@@ -30411,10 +30411,11 @@
 pdfEndPage
 %%Page: 2 2
 %%BeginPageSetup
-%%PageOrientation: Portrait
+%%PageOrientation: Landscape
 pdfStartPage
-90 rotate
-123.5 -718.5 translate
+180 rotate
+-585.834 -792 translate
+0.9406 0.9406 scale
 0 0 595 842 re W
 %%EndPageSetup
 [] 0 d
@@ -30429,6 +30430,8 @@
 [0] SC
 false op
 false OP
+0 0 595 842 re
+W
 q
 q
 1 i


Comment 2 Tim Waugh 2007-04-18 13:07:41 UTC
Actual vs expected diff for post-filters output:

--- dayplanner-ps.ps    2007-04-18 13:07:12.000000000 +0100
+++ dayplanner-working-ps.ps    2007-04-18 13:06:58.000000000 +0100
@@ -1548,7 +1548,7 @@
 %%PageOrientation: Portrait
 pdfStartPage
 90 rotate
-123.5 -718.5 translate
+0 -842 translate
 0 0 595 842 re W
 %%EndPageSetup
 [] 0 d
@@ -30499,7 +30499,7 @@
 %%PageOrientation: Portrait
 pdfStartPage
 90 rotate
-123.5 -718.5 translate
+0 -842 translate
 0 0 595 842 re W
 %%EndPageSetup
 [] 0 d


Comment 3 Tim Waugh 2007-05-09 13:02:50 UTC
Same root cause as bug #236753.

*** This bug has been marked as a duplicate of 236753 ***


Note You need to log in before you can comment on or make changes to this bug.