Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236753 - Known-good PDF handling problem (Kew Gardens strolling map)
Summary: Known-good PDF handling problem (Kew Gardens strolling map)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
: 236756 (view as bug list)
Depends On:
Blocks: FC6Update
TreeView+ depends on / blocked
 
Reported: 2007-04-17 15:13 UTC by Tim Waugh
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 1.2.10-7.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-22 08:06:09 UTC


Attachments (Terms of Use)
cups-pdftops-landscape.patch (deleted)
2007-04-18 11:39 UTC, Tim Waugh
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
CUPS Bugs and Features 2348 None None None Never

Description Tim Waugh 2007-04-17 15:13:07 UTC
Description of problem:
This PDF document:
https://www.rbgkew.org.uk/visitor/maps/strollingmap.pdf

does not print correctly.

Version-Release number of selected component (if applicable):
cups-1.2.10-3.fc6

How reproducible:
100%

Steps to Reproduce:
1. lp strollingmap.pdf
  
Actual results:
Lots of blank space around the top and the left edge of the resulting landscape
page, with cropped right and bottom edges.

Expected results:
As shown in evince.

Comment 1 Tim Waugh 2007-04-17 15:14:27 UTC
Printing to file from xpdf gives a working PS file, compared to the broken file
produced by the CUPS pdftops filter.  Diff:

--- strollingmap-cups.ps        2007-04-17 15:57:59.000000000 +0100
+++ strollingmap-xpdf.ps        2007-04-17 15:58:28.000000000 +0100
@@ -1,12 +1,9 @@
 %!PS-Adobe-3.0
-%cupsRotation: 270
-%Producer: xpdf/pdftops 3.01
-%%Creator: Adobe Illustrator 10
-%%Title: untitled
+%%Creator: xpdf/pdftops 3.01
 %%LanguageLevel: 2
 %%DocumentSuppliedResources: (atend)
-%%DocumentMedia: plain 595 842 0 () ()
-%%BoundingBox: 0 0 595 842
+%%DocumentMedia: plain 612 792 0 () ()
+%%BoundingBox: 0 0 612 792
 %%Pages: 1
 %%EndComments
 %%BeginDefaults
@@ -615,14 +612,15 @@
   /eth/ntilde/ograve/oacute/ocircumflex/otilde/odieresis/divide
   /oslash/ugrave/uacute/ucircumflex/udieresis/yacute/thorn/ydieresis]
 pdfMakeFont
-595 842 false pdfSetup
+612 792 false pdfSetup
 %%EndSetup
 %%Page: 1 1
 %%BeginPageSetup
-%%PageOrientation: Landscape
+%%PageOrientation: Portrait
 pdfStartPage
-180 rotate
--718.5 -719 translate
+90 rotate
+0 -586.304 translate
+0.9406 0.9406 scale
 0 0 842 596 re W
 %%EndPageSetup
 [] 0 d
@@ -637,6 +635,8 @@
 [0] SC
 false op
 false OP
+0 0 841.89 595.275 re
+W
 q
 q
 1 i


Comment 2 Tim Waugh 2007-04-17 16:49:12 UTC
Reported upstream.

Comment 3 Tim Waugh 2007-04-18 11:39:46 UTC
Created attachment 152890 [details]
cups-pdftops-landscape.patch

This patch rectifies the problem, but I'm not convinced it is correct.

Comment 4 Tim Waugh 2007-04-18 12:51:04 UTC
Here is the diff between the final (i.e. after pdftops|pstops filters) output
and a correct-looking result:

--- strollingmap-ps.ps  2007-04-18 11:08:49.000000000 +0100
+++ strollingmap-working-ps.ps  2007-04-18 11:32:03.000000000 +0100
@@ -705,7 +705,7 @@
 %%PageOrientation: Landscape
 pdfStartPage
 180 rotate
--718.5 -719 translate
+-842 -586.304 translate
 0 0 842 596 re W
 %%EndPageSetup
 [] 0 d


Comment 5 Tim Waugh 2007-05-09 13:02:52 UTC
*** Bug 236756 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2007-05-21 22:44:43 UTC
Fixed in update: cups-1.2.10-7.fc6


Note You need to log in before you can comment on or make changes to this bug.