Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236702 - /bin/vi (vim-minimal) online help doesn't work
Summary: /bin/vi (vim-minimal) online help doesn't work
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: vim
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Karsten Hopp
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-17 06:54 UTC by Yan Li
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-05 20:31:39 UTC


Attachments (Terms of Use)

Description Yan Li 2007-04-17 06:54:04 UTC
+++ This bug was initially created as a clone of Bug #173974 +++

Description of problem:
Because vim help files are compressed, and because minimal vim cannot understand
advance settings in /etc/vimrc which might otherwise help (eg autocmd), when
viewing help with /bin/vi all you get is compressed garbage on the screen.

This kind of error (garbaged display, no reasonable error message) should not
appear in an Enterprise level product.  If vim-minimal doesn't support online
help, a reasonable error message should be displayed if the user went there.

Since now RHEL5 supports VM in Xen, we often do minimal installation of RHEL5
for VMs which uses vim-minimal, so this bugs can often be observed.


Version-Release number of selected component (if applicable):
vim-minimal-7.0.109-3

How reproducible:
Always

Steps to Reproduce:
1./bin/vi
2.:help index
  

Actual Results:  
1. normal vi startup
2. indigestible garbage on screen


Expected Results: 
Should see a help screen


Additional info:

And I believe that this bug exists on all platforms.

To manually fix:

cd /usr/share/vim/vim63/doc
gunzip *.txt.gz
vim
    :helptags /usr/share/vim/vim63/doc
    :q

-- Additional comment from redhat@zacglen.com on 2007-04-10 20:20 EST --
Applicable to Fedora Core 6. Sorry about that.

Comment 2 Steve Bonneville 2007-05-07 20:04:13 UTC
This is exactly the issue reported for Fedora Core 6 in bug #173974.  I also see
this on x86 with vim-{minimal,common,enhanced} installed, so I believe this is
not confined to powerpc.  Reported by training students in class.

The ':help index' command breaks when vim is called as /bin/vi, but works when
wim is called as /bin/vim.  

In addition, the /etc/profile.d/vim.sh file in RHEL5 aliases vi to vim for users
with UID greater than 100, but not for root!  So this problem becomes obvious
for anyone who runs vi as root instead of vim.

The ':help version7' function, along with a rotating collection of others, is
also advertised by /bin/vi when started without a file; they should work as the
program specifies at startup.


Comment 3 RHEL Product and Program Management 2007-06-05 20:31:39 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Since this
bugzilla is in a component that is not approved for the current
release, it has been closed with resolution deferred.  You may
reopen this bugzilla for consideration in the next release.


Note You need to log in before you can comment on or make changes to this bug.