Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236695 - anaconda or yum fails to fetch comps.xml from Extras repo with FTP
Summary: anaconda or yum fails to fetch comps.xml from Extras repo with FTP
Keywords:
Status: CLOSED DUPLICATE of bug 231543
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-17 03:45 UTC by G.Wolfe Woodbury
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-18 14:02:14 UTC


Attachments (Terms of Use)
vsftp log extract showing no attempt to fetch comps.xml (deleted)
2007-04-17 03:45 UTC, G.Wolfe Woodbury
no flags Details

Description G.Wolfe Woodbury 2007-04-17 03:45:23 UTC
Description of problem:
   installer will not properly fetch and use the "Group" information from the
comps.xml file in the Extras-development repo when adding the repo and doing a
"customize now" sequence.


Version-Release number of selected component (if applicable):
    anaconda-11.2.0.49-1
    yum-3.1.6-1


How reproducible:
    very consisten here - always


Steps to Reproduce:
1. boot rawhid boot.iso
2. add extras-development repository
3.
  
Actual results:
    installer complains via a dialog box that it could not find the group data
for the repository and that it won't allow you to select any extras packages
during the customize now sequence.


Expected results:
    It should fetch and read the comps.xml file and let the user select extras
packages.


Additional info:

  I realize that the merger is pending and this may become moot, but the symptom
is more general.  FTP (and http) access to other repositories should properly
fetch and read the comps.xml information.

   I'm using FTP to a vsftp server on an FC6 local mirror.  I have carefully
examined the logs (extract attached) for the transactions, and there is no
attempt to fetch the comps.xml file in the logs.

Comment 1 G.Wolfe Woodbury 2007-04-17 03:45:23 UTC
Created attachment 152760 [details]
vsftp log extract showing no attempt to fetch comps.xml

Comment 2 G.Wolfe Woodbury 2007-04-18 12:59:04 UTC
I have verified that http method also fails to fetch the comps.xml file.

Comment 3 Jeremy Katz 2007-04-18 14:02:14 UTC
There seems to be something up with multiple repositories in general in anaconda
right now.  On my whiteboard as one of the things I'm hoping to fix today...

*** This bug has been marked as a duplicate of 231543 ***


Note You need to log in before you can comment on or make changes to this bug.