Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236664 - Cannot compile apr applications, apr-i386.h contains x86_64'ishs typedef
Summary: Cannot compile apr applications, apr-i386.h contains x86_64'ishs typedef
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: apr
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-17 01:36 UTC by Chmouel Boudjnah
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-17 08:19:48 UTC


Attachments (Terms of Use)
Type fixes on 32 (deleted)
2007-04-17 01:36 UTC, Chmouel Boudjnah
no flags Details | Diff

Description Chmouel Boudjnah 2007-04-17 01:36:59 UTC
Description of problem:

Cannot compile apr applications, apr-i386 contains x86_64'ishs

Version-Release number of selected component (if applicable):

apr-devel-1.2.7-11

How reproducible:

compile PHP or anitything that require apr.h

Will just going to attach patch which should explain everything

Comment 1 Chmouel Boudjnah 2007-04-17 01:36:59 UTC
Created attachment 152734 [details]
Type fixes on 32

Comment 2 Joe Orton 2007-04-17 08:19:48 UTC
Thanks for contacting us.

This is not a bug; it's an expect part of LFS support in APR.

To build applications against APR, you need to pass the output of

 `apr-1-config --cppflags --cflags --includes`

to the compiler.  This will ensure the off64_t type is defined.  Recent versions
of PHP do this automatically.


Note You need to log in before you can comment on or make changes to this bug.