Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236661 - Menu launcher does not start app
Summary: Menu launcher does not start app
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-lvm
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jim Parsons
QA Contact: Jim Parsons
URL:
Whiteboard:
Depends On:
Blocks: FC7Blocker
TreeView+ depends on / blocked
 
Reported: 2007-04-17 01:27 UTC by Pete Zaitcev
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-15 19:57:38 UTC


Attachments (Terms of Use)
Dialog (deleted)
2007-04-17 01:32 UTC, Pete Zaitcev
no flags Details

Description Pete Zaitcev 2007-04-17 01:27:14 UTC
Description of problem:

When invoking "Logical Volume Management" menu item, I get an error
dialog "Unknown error". Very cute (to be attached). Running
system-config-lvm works fine from a command line.

Version-Release number of selected component (if applicable):

system-config-lvm-1.0.18-1.2.FC6
  (yes, this is what Rawhide has currently)

How reproducible:

100%

Steps to Reproduce:
1. Log into GNOME desktop
2. Select "System" -> "Administration" -> Logical Volume Management
   (horizontal cyan stroke for icon).
  
Actual results:

Error dialog.

Expected results:

Starting system-config-lvm

Additional info:

This bug may be better filed against a GNOME component, but I thought
the menus are carried by applications. I looked at this file:
 /usr/share/applications/system-config-lvm.desktop
Seems like an OK menu entry...

Comment 1 Pete Zaitcev 2007-04-17 01:32:28 UTC
Created attachment 152732 [details]
Dialog

Comment 2 Jeremy Katz 2007-04-30 15:35:56 UTC
This really needs to be fixed for F7 final or we should probably pull
system-config-lvm from all installs.

Comment 3 Will Woods 2007-04-30 19:41:50 UTC
system-config-lvm works for me... on systems that are actively using LVM.

It does, in fact, fail with "Unknown error" on the one machine where I'm using
plain partitions. Is your machine not using LVM?

Comment 4 Will Woods 2007-04-30 21:55:34 UTC
Also interesting: It works when run as root, but not when run as a normal user.
So at least there's a workaround.. kinda.

Comment 5 Tyler Owen 2007-05-01 20:07:16 UTC
I am seeing this error as well.  If I run system-config-lvm from either the menu
or the command line as a normal user I get the error.  However if I run it from
the command line as root it works OK??  

I do have LVM configured.

Comment 6 Jim Parsons 2007-05-01 21:59:05 UTC
This is because pam was misconfigured - not using the new include directives.
This has been fixed and has been built into the latest fc7 today...and yes, I
received a dispensation from rel-eng :)

Sorry for the unpleasantness...


Note You need to log in before you can comment on or make changes to this bug.