Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236653 - Software Installer fails on "point and click" pkg install
Summary: Software Installer fails on "point and click" pkg install
Keywords:
Status: CLOSED DUPLICATE of bug 236142
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut
Version: rawhide
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-16 23:13 UTC by dean owensby
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-24 22:03:13 UTC


Attachments (Terms of Use)

Description dean owensby 2007-04-16 23:13:22 UTC
Description of problem:
Software Installer fails to install packages in gui mode, after rpm file icon is
clicked over with mouse. bugzilla output is the result.

Version-Release number of selected component (if applicable):
unknown: FC7 test 3 from live-cd; built to gaming/multimedia platform with devel
support.


How reproducible:
Click #1 mouse-button when cursor is over file icon (in this test-case, rpm for
freshrpms' mplayer pkg). does the same for any rpms downloaded with the
package-installer prompt selected, as well, under firefox, or seamonkey


Steps to Reproduce:
1.saa
2.or select default Package Installer on prompt during download
3.
  
Actual results:buzilla crash output similar to below


Expected results:normal rpm check, dep/conflict check, trans check,
install/update, cleanup.


Additional info:
Component: Software Installer
Summary: TBfb3b95f0
system-install-packages:126:_populateLocalPackages:NameError: global name 'rpm'
is not defined

Traceback (most recent call last):
  File "/usr/sbin/system-install-packages", line 346, in <module>
    main()
  File "/usr/sbin/system-install-packages", line 342, in main
    pkginst.run()
  File "/usr/sbin/system-install-packages", line 332, in run
    self.doRefresh()
  File "/usr/sbin/system-install-packages", line 94, in doRefresh
    self.populatePackages()
  File "/usr/sbin/system-install-packages", line 275, in populatePackages
    self._populateLocalPackages(locals)
  File "/usr/sbin/system-install-packages", line 126, in _populateLocalPackages
    if po.hdr[rpm.RPMTAG_SOURCEPACKAGE] == 1: # ugh.
NameError: global name 'rpm' is not defined

Local variables in innermost frame:
installs: []
self: <__main__.SinglePackageInstaller object at 0x87af20c>
pkgs: ['/home/lib/mplayer/mplayer-1.0-0.34.rc1try2.fc6.i386.rpm']
pkg: /home/lib/mplayer/mplayer-1.0-0.34.rc1try2.fc6.i386.rpm
po: mplayer - 1.0-0.34.rc1try2.fc6.i386
updates: []

Comment 1 Jens Knutson 2007-04-19 07:12:57 UTC
I get the very same results trying to install different packages.

(Also, should severity really be "low" for something this visible?)

Comment 2 Jeremy Katz 2007-04-24 22:03:13 UTC

*** This bug has been marked as a duplicate of 236142 ***


Note You need to log in before you can comment on or make changes to this bug.