Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236604 - Duplicate message when deleting profile [satellite]
Summary: Duplicate message when deleting profile [satellite]
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other
Version: 360
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Justin Sherrill
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-16 18:37 UTC by daryl herzmann
Modified: 2007-10-15 20:39 UTC (History)
2 users (show)

Fixed In Version: rhn502
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-15 20:39:58 UTC


Attachments (Terms of Use)
Duplicate message shown (deleted)
2007-04-16 18:37 UTC, daryl herzmann
no flags Details

Description daryl herzmann 2007-04-16 18:37:28 UTC
Delete system profile on RHN hosted, two "System profile deleted" messages
appear.  I'll attach a screenshot.  Hopefully this bug isn't a dup!

Comment 1 daryl herzmann 2007-04-16 18:37:29 UTC
Created attachment 152709 [details]
Duplicate message shown

Comment 2 daryl herzmann 2007-05-17 02:34:30 UTC
still exists on rhn501

Comment 4 daryl herzmann 2007-08-06 16:20:36 UTC
I'm not sure why this bug was closed, it still exists on rhn502 hosted.

Comment 5 Máirín Duffy 2007-08-06 16:50:35 UTC
did this get fixed on sat or hosted? (or both?)


Comment 6 daryl herzmann 2007-09-11 16:53:02 UTC
Definetely did not get fixed on hosted as I just reproduced it again.

Comment 7 daryl herzmann 2007-09-26 14:09:55 UTC
still in rhn5.0.3 :( 

Comment 9 Máirín Duffy 2007-09-26 16:51:30 UTC
Hi Daryl, I apologize for the confusion; this bug is actually filed as an RHN
Satellite bug, so I've cloned it in bug 307351 and cc'ed you to the new bug for
it to be specifically addressed for RHN Hosted. Just so you know, the bug is
currently being evaluated for potential inclusion in RHN Hosted version 5.05.
Thanks for calling attention to this!

Comment 10 daryl herzmann 2007-09-26 17:02:22 UTC
Thanks,

This bug was not filed against the Satellite, in fact, you just changed the
component to be Satellite.  Like 307351, it was filed against RHN/Website.


daryl

Comment 11 Máirín Duffy 2007-09-26 19:31:17 UTC
Hi Daryl,

It actually was filed against Satellite. Back when it was first filed, there was
only one "Red Hat Network" component in Bugzilla, and it was used for both
Satellite and RHN Hosted bugs. Since after the bug was originally filed, though,
those two products have been given their own separate areas in Bugzilla. Not all
of the bugs have been completely sorted into the respective buckets yet so I
while I was working on the bug I thought it would be a good idea to move it into
the Satellite bucket so it was more publicly apparent that it was a Satellite bug.

We actually have a system to identify RHN Hosted vs RHN Satellite bugs though
that predates having two separate Bugzilla components. That system involves
aligning the bugs to a 'blocker' bug (typically a triage bug specific to the
product) as well as an approval system. While the bug was aligned to both
satellite and hosted triage bugs (which it should not have been), it had also
already gone through a 3-step approval process very specific to Satellite, and
it also was assigned to a Satellite engineer. Based on that, it was clearly a
Satellite bug, and it would save my team's time for me to create a new hosted
bug rather than putting a new Satellite bug through the 3-step approval process
again and converting this to a hosted bug.

Daryl, I understand how you could have thought I just moved it after the fact,
but that would be dishonest and stupid and I hope you know me personally well
enough to know that I wouldn't lie to you or any other customer like that (nor
would any Red Hat employee that I know of.) 

Sorry for not being more clear about this, I hope this background helps explain
the situation to you. Some of the involved bugzilla components I think are
probably private to Red Hat employees so I am sure it wasn't at all obvious to
you as it was to me when I wrote the comment.

Sorry again,
Máirín

Comment 12 daryl herzmann 2007-09-26 20:56:43 UTC
Thanks Máirín,

I see what's going on now.  As you have heard us complain about before, it is
impossible for us to track the various automated tracker/blocker bugs, since
they are invariably private.  We have to rely on helpful redhatters to translate
the bugzilla entries for us mere mortals to figure out where are bugs are at.

daryl

Comment 13 Justin Sherrill 2007-10-15 20:39:58 UTC
Daryl,

After speaking with John, it appears that this is either Org related or user
related (my testing on webQA seemed to indicate that it is user related).  Thus
since i cannot reproduce on satellite I'm going to go ahead and close this BZ. 
I have added a few private comments to BZ 307351 detailing some of my findings
to hopefully help the hosted team with their fix, (I have made it private since
it includes some user names in the post).  If you would be interested in any
details of my small findings please feel free to contact me directly.

-Justin


Note You need to log in before you can comment on or make changes to this bug.