Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236557 - Samba users not visible.
Summary: Samba users not visible.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-samba
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-16 13:26 UTC by Richard Steck
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-17 14:56:42 UTC


Attachments (Terms of Use)

Description Richard Steck 2007-04-16 13:26:34 UTC
Description of problem:  I add a new Samba user in Preferences > Add User.  
Then I OK the user.  The user works.   When I return to Prefs > Add User, the 
user is not visible.   If I try to add the user again, it says the user already 
exists--yet the user is not visible.


Version-Release number of selected component (if applicable): Samba Config Tool 
1.2.39.   Kernel 2.6.20-1.3069.fc7


How reproducible:


Steps to Reproduce:
1.Add user to Samba Users with Samba Config Tool, Prefs > Add User. Exit tool.
2.
3.
  
Actual results:  Return to Samba Config Tool  Prefs > Add User.   No users 
shown, yet User exists.


Expected results:
List of Users should show.

Additional info:  This is an old bug that was reported in #159419.   It seems 
to have popped up again.

Comment 3 Nils Philippsen 2007-04-17 12:46:56 UTC
New bugs shouldn't be filed against "testN", only against "devel".

Comment 4 Nils Philippsen 2007-04-17 14:56:42 UTC
The problem was a different one than in bug #159419, though. Up to now,
system-config-samba read /etc/samba/smbpasswd directly instead of using the
pdbedit tool and when the default changed from using the smbpasswd file to using
a tdb backend, it couldn't cope with that, i.e. users where added to the passdb
TDB file, but system-config-samba still looked for /etc/samba/smbpasswd.

system-config-samba-1.2.40 is building right now which contains fixes for this bug.

Please test extensively as the new code is sufficiently different that I might
have broken something ;-). If the fix doesn't help you, please reopen this
ticket, if it introduces other bugs, please open new bugzilla tickets. Thanks.


Note You need to log in before you can comment on or make changes to this bug.